Itoo Software Forum

Author Topic: Error using some Chinese characters in some locations  (Read 307 times)

QN1156

  • Newbie
  • *
  • Posts: 30
Error using some Chinese characters in some locations
« on: July 01, 2022, 06:45:19 PM »
Hi:
I found that using some Chinese characters in these positions will cause errors or invalid problems. I hope to repair these problems. This brings me a lot of trouble, Thank you very much!
« Last Edit: July 01, 2022, 06:48:27 PM by QN1156 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4126
    • iToo Software
Re: Error using some Chinese characters in some locations
« Reply #1 on: July 04, 2022, 12:16:48 PM »
Hi, according to our tests, the Customize RC Spline dialog accepts chinese characters, but these are not displayed correctly in the 3DS Max modifier.
Is that correct, or did you notice other issue ?

Regarding the Library browser, RailClone uses yet the old browser, which is not compatible with Unicode characters.
We have plans to replace it with the new one (the same used in latest Forest versions). That should fix this problem.

Thanks for reporting it. We'll work to fix these issues.

Carlos Quintero
iToo Software

QN1156

  • Newbie
  • *
  • Posts: 30
Re: Error using some Chinese characters in some locations
« Reply #2 on: July 04, 2022, 03:43:01 PM »
"The Custom RC Spline dialog accepts Chinese characters, but these are displayed incorrectly in the 3DS Max modifier." Yes, if "User Deta Fields" uses incompatible characters the 3DS Max modifier will not show. My custom "sets" cannot be selected in the 3DS Max modifier if the "sets" name uses incompatible characters.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4126
    • iToo Software
Re: Error using some Chinese characters in some locations
« Reply #3 on: July 05, 2022, 11:16:24 AM »
Problem with RC Spline User Data sets is already fixed for next update.

Changes in Library browser will take more time, because is not a minor change (probably for next beta/major release).
Carlos Quintero
iToo Software

QN1156

  • Newbie
  • *
  • Posts: 30
Re: Error using some Chinese characters in some locations
« Reply #4 on: July 09, 2022, 05:07:37 AM »
Hi:
After Railclone is updated to the latest version 5.2.6, The problem that RC Spline->User Data Sets is incompatible with some Chinese has not been resolved, Such as Chinese "开".

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4126
    • iToo Software
Re: Error using some Chinese characters in some locations
« Reply #5 on: July 11, 2022, 12:33:01 PM »
Comfimed. It's already fixed for next update.
Carlos Quintero
iToo Software