Itoo Software Forum

Author Topic: Escalator problem  (Read 116 times)

DT2656

  • Newbie
  • *
  • Posts: 15
Escalator problem
« on: March 17, 2021, 07:34:42 AM »
RC 4.2.1 the steps of the escalator from the library are directed along the path, a problem common to all three styles. How to fix it?

REDVERTEX

  • Newbie
  • *
  • Posts: 16
Re: Escalator problem
« Reply #1 on: March 17, 2021, 08:22:35 AM »
You can check the reverse checkbox in Parameters rollout  ;)

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3261
    • iToo
Re: Escalator problem
« Reply #2 on: March 17, 2021, 09:27:15 AM »
Here is fixed escalator styles. Feel free to replace them at installed location:
%localappdata%\Itoo Software\RailClone Pro\lib\default1\Architecture\Interior\Escalators\objects

One note: spline direction matters for these styles. So if something is wrong try reversing it.
Rokas
iToo Software

DT2656

  • Newbie
  • *
  • Posts: 15
Re: Escalator problem
« Reply #3 on: March 17, 2021, 10:01:27 AM »
Thank. Replaced the files in the library with yours and it worked. It turns out that the problem was in the libraries.
Will you replace escalators with fixed files in Update manager?

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3261
    • iToo
Re: Escalator problem
« Reply #4 on: March 17, 2021, 10:10:53 AM »
We will update via update managers.
We just need to solve some versioning issues, like in this example: in the versions this style was created (I believe v2) it worked correctly. And for new RC versions it needs some changes.

Rokas
iToo Software