Itoo Software Forum

Author Topic: Geometry gets cut off at Spline Vertex  (Read 1619 times)

Michael Betke

  • Newbie
  • *
  • Posts: 17
Geometry gets cut off at Spline Vertex
« on: August 13, 2013, 02:43:29 PM »
I may have a simple to solve problem but I'm really stuck with it. I do a lot of generic buildings with a simple setup.

It has just one simple closed spline and I add some variations with the Sequence and Randomize nodes (really cool!).

But as you can see on the edges of my buildings it seems the windows just get cut off and on the continuing segment of the spline it also looks wired.
I would like to avoid it and have my Segments start with the next Vertex of my spline so it doesn't look that cut off.

Is there a way to do it?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Geometry gets cut off at Spline Vertex
« Reply #1 on: August 13, 2013, 03:08:11 PM »
What about adding the windows as Evenly segments ?

If you turn on Generator->Evenly->Justify they will be centered on short paths, avoiding that segments are sliced by the corners.
Carlos Quintero
iToo Software

Michael Betke

  • Newbie
  • *
  • Posts: 17
Re: Geometry gets cut off at Spline Vertex
« Reply #2 on: August 13, 2013, 03:23:56 PM »
Yes this worked! :)
I made my plain wall as the default segment with the Window/Wall sequence the evenly part.

Another minor:
In your videos your viewport gets updated as soon as you work in the style editor. I have to click with my mouse into the viewport to get the update and then back into style editor to make new changes. 
If I stay in the style editor I see no result. Is there something I need to setup to make the instant viewport update of my changes work?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Geometry gets cut off at Spline Vertex
« Reply #3 on: August 13, 2013, 04:16:02 PM »
Quote
If I stay in the style editor I see no result. Is there something I need to setup to make the instant viewport update of my changes work?

Not really, it may be a bug. Anyway, for the next update we are introducing deep changes in the style editor. Hopefully this problem is already solved.
Carlos Quintero
iToo Software