Itoo Software Forum

Author Topic: Linear 1S not doing corners  (Read 553 times)

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Linear 1S not doing corners
« on: May 26, 2015, 04:30:29 PM »
Hello,

I have a style that is 2 linear 1S using the same spline.
The red circle is showing the failure of creating the corner for that segment.
The other segment, is handling the corner as desired.
I've tried everything I could think of but it will not cover the corner.
Why does this segment behave so differently?  I have the segments copied from each other.

Thank you,
TL1895
« Last Edit: May 26, 2015, 04:32:26 PM by TL1895 »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Linear 1S not doing corners
« Reply #1 on: May 26, 2015, 04:32:46 PM »
Hi,

Would you mind uploading the file so I can take a look at this issue in detail? If you'd prefer not to upload it here, please feel free to send it to support@itoosoft.com.

Many thanks,

Paul
Paul Roberts
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: Linear 1S not doing corners
« Reply #2 on: May 26, 2015, 04:38:38 PM »
I'll send it, thank you Paul.
So far, it seems that it is related to the pivot of the channel shaped segment.
Both segments share a pivot (based on a column centerline) so I thought they'd work using pivot alignment.

Thank you,
TL1895

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: Linear 1S not doing corners
« Reply #3 on: May 26, 2015, 05:51:13 PM »
I have had to move on for now, but I ended up creating a second spline to use for the C-shaped segment, and then adjusted the segment to align Y to "bottom."
Hopefully there is a way for this to work using one spline, as there will be more parts to add, and I don't want to draw a new spline each time...
Thanks again,
TL1895

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Linear 1S not doing corners
« Reply #4 on: May 26, 2015, 06:21:24 PM »
Hi,

You are correct that this is a limitation of using the pivot but  there is a workaround you can use to make the style work as you intended. First add an empty "null" segment to the Corner input and give the segment a Fixed Size > X value of 5'0 . This adds an empty corner segment that will be used to calculate the spacing of the adjacent default segments. Next increase the generator's BC Offset value so that the corner closes up, a value of 150% worked for this example.

I've sent the file back to you, please let me know if I can help further.

Kind regards,

Paul

Paul Roberts
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: Linear 1S not doing corners
« Reply #5 on: May 26, 2015, 06:29:37 PM »
Hi Paul,

Thanks for the help.  I'll check it out asap, but it sounds better than my current workaround...

Thank you,
TL1895