Itoo Software Forum

Author Topic: massive rendering slowdown  (Read 448 times)

rivoli

  • Newbie
  • *
  • Posts: 15
massive rendering slowdown
« on: July 20, 2017, 04:54:26 PM »
I'm having some major problem with a couple of scenes in which one or even a few railclone objects out of several seem to cause serious rendering performance loss, with cpus oscillating wildly between 100% to 20% down to as low as 1% or 2%.
I have no clue on what may cause this, as everything seems to work fine one moment and without any change to any particular railclone object it randomly happens.
in one particular scene I have several objects with one causing rendering to slow down considerably. if I disable it things go back to normal, sort of, with cpus working between 99% and 90%, and if I disable a whole bunch of other objects, leaving a few still active, rendering is back at 100%.
it all seems very random to me, maybe someone can shed some light?
3ds max 2017, vray 3.60.01 and railclone pro 3.0.7 here.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: massive rendering slowdown
« Reply #1 on: July 21, 2017, 12:17:40 PM »
Hi,

Sorry to hear you're facing these troubles. If possible, please send us the problematic scene to analyse it here. Thanks in advance.

Best regadrs,

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: massive rendering slowdown
« Reply #2 on: July 21, 2017, 12:50:26 PM »
Besides sending us the scene, please try this:

- Change in the Windows registry: HKEY_LOCAL_MACHINE\SOFTWARE\Itoo Software\RailClone Pro\DynamicGeometry, from 1 to 0.
- Restart Max and try again. Is there some difference ?

Also it would be interesting to check if problem happens also in previous V-Ray versions (as 3.50.04), or it's exclusive of V-Ray 3.6.

Thanks,

Carlos Quintero
iToo Software

rivoli

  • Newbie
  • *
  • Posts: 15
Re: massive rendering slowdown
« Reply #3 on: July 21, 2017, 03:25:29 PM »
thank you for the fast replies. I tried changing the registry key, but it didn't make any difference. the scene still renders with cpus working quite unevenly.
as you suspected it renders perfectly fine with vray 3.50.04 though. should have tried this earlier, but I've been kind of snowed under for a few days and didn't have the time.
I can still pack a stripped down version of the scene and send it over if you like, if you think it may be useful.


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: massive rendering slowdown
« Reply #4 on: July 21, 2017, 03:55:42 PM »
Yes, please send us the stripped scene.

Probably we have to contact with ChaosGroup, because from our side the RailClone code for V-Ray 3.5 and 3.6 is identical.
Do you mind if we send your scene to them ?

Thanks.
Carlos Quintero
iToo Software

rivoli

  • Newbie
  • *
  • Posts: 15
Re: massive rendering slowdown
« Reply #5 on: July 21, 2017, 04:04:44 PM »
not at all, that's ok with me. I managed to consistently reproduce the problem with a very simple scene made of just a few rc objects. I'll send it over soon.

rivoli

  • Newbie
  • *
  • Posts: 15
Re: massive rendering slowdown
« Reply #6 on: July 21, 2017, 04:28:42 PM »
scene sent, thanks for looking into it.

FC1888

  • Newbie
  • *
  • Posts: 42
Re: massive rendering slowdown
« Reply #7 on: July 24, 2017, 11:50:42 PM »
rivoli, I noticed you initially tested this with Vray 3.60.01, might also be worth upgrading to Vray 3.60.02 and trying it with that.. you never know. I am definitely no expert, but worth trying I think

JTP Vis

  • Full Member
  • ***
  • Posts: 107
Re: massive rendering slowdown
« Reply #8 on: July 25, 2017, 11:29:34 AM »
I have had a similar problem before, but not (I don't think) connected with Railclone or Forest Pack. I noticed this problem in the past when I was rendering very large scenes using distributed rendering with many additional buckets. I contacted Chaos group about it and it was suggested that it was a problem with the render management within vray. The solution (which I use regularly now in order to get a more stable rendering experience) was to use a script to set the number of cores used for rendering to lower than the total number available on the local machine. I use a workstation with 2 CPUs that are hyperthreaded, so there are 24 virtual cores. You can't (aparently) only disable 1 virtual core (from the rendering engine), you have to disable 1 real core, which is therefore two virtual cores.

The script is very simple, just one line of code:

renderers.current.system_numThreads=22

Where 22 is the number of virtual cores you have on your local machine, minus 2 (if your machine is hyperthreaded). This script can be run at render time, through the render dialogue. You can make this line of code into a run-able max script by simply pasting it into a notepad document, and saving it with the suffix .ms

This will set the current session of max to only use the number of cores set to render with, which will leave 2 cores available for render management.

Restarting max will reset this setting, or running the script with the full number of cores will also reset it.


There is also another possible problem that you might be facing: throttling due to memory restriction! It would be a memory setting within vray that could cause this. If you have a very large amount of assets, particularly v-ray proxies, then the "dynamic memory limit" from the render "settings" tab, and the "System" seciton, will kick in. By default it is set to 4000MB. If you are using a very large amount of assets, this limit maxes out and there is a constant loading and unloading of assets in order to continue to render. This (I believe) can mean that the CPU doesn't have much to do while this loading and unloading is happening. It can be solved by increasing the memory limit so that there is more available, or, if you have a very large amount of RAM, you can set it to 0, which according to the Chaosgroup help page is a special value that removes the restriction on the memory limit and uses all that it needs.


It could be either of these things causing your problem, or something else, but I hope you find a solution to your problem.

Bill

rivoli

  • Newbie
  • *
  • Posts: 15
Re: massive rendering slowdown
« Reply #9 on: July 25, 2017, 05:25:37 PM »
totally missed there was a new version available, I would have certainly upgraded if I'd known.
meanwhile I got in touch with itoo's support team and they quickly found a solution. outstanding work from their part as usual.