Itoo Software Forum

Author Topic: Material Id expression Corona 1.6 error  (Read 979 times)

HM7207

  • Newbie
  • *
  • Posts: 3
Material Id expression Corona 1.6 error
« on: May 20, 2017, 08:28:06 PM »
Hi,

I think there is a bug I trying to change Material Id of element regardin Spline ID
All work well With Standard Material BUT with Corona 1.6  It is random, or not working

viewport is OK, But not render try the same with an One old File you gave with the correct expression, but... Only one material appear on render.

If you have any idea,




Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1609
Re: Material Id expression Corona 1.6 error
« Reply #1 on: May 22, 2017, 12:41:56 PM »
Hi,

I'm afraid Corona's instancing system doesn't allow for changes to material IDs or UVW mapping. As a result some features aren't supported by Corona, you can see a full list here: http://docs.itoosoft.com/railclone/requirements

Fortunately you can get around this if you don't mind disabling instancing. Just go to the Display rollout and turn off Use Instancing Engine.

I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software

HM7207

  • Newbie
  • *
  • Posts: 3
Re: Material Id expression Corona 1.6 error
« Reply #2 on: May 23, 2017, 10:30:32 AM »
Thanks Paul,

I read about the issue... and as you suggest I switch instanc engine

And I try Too to  assigned a new material and a new spline. very easy to do , because of only two spline and 2 objects.

Corana can't be THAT good ! :)


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1609
Re: Material Id expression Corona 1.6 error
« Reply #3 on: May 23, 2017, 11:24:20 AM »
That's a nice easy solution too  :)
Paul Roberts
iToo Software