Itoo Software Forum

Author Topic: Material ID Strange  (Read 1389 times)

TQ2576

  • Newbie
  • *
  • Posts: 12
Material ID Strange
« on: September 15, 2014, 08:25:29 AM »
I have what I thought was a simple office ceiling.  I am not getting the correct material Id's and I have tried creating this 4 different ways.  The only way I can get this to work so far has been to split up the set into a grid RailClone and a Tile RailClone so that the materials work correctly. 

Anyone have any thoughts on how to get this to work correctly
« Last Edit: September 15, 2014, 12:48:47 PM by TQ2576 »

Rokas

  • Sr. Member
  • ****
  • Posts: 406
Re: Material ID Strange
« Reply #1 on: September 15, 2014, 09:50:13 AM »
Hi,

to my understanding You did everything fine, except You didn't assign correct material to your segments.

You should assign the same material to every segment, as to Your railclone object.

And after that- assign correct material IDs to your segments.


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Material ID Strange
« Reply #2 on: September 15, 2014, 10:49:41 AM »
Hi,

Rokas is correct, this RailClone object is fine as it is you just need to assign the correct Material IDs to the geometry used as segments. Unlike Forest, RailClone does not automatically collate all the materials used on the segments into a new Multi Sub object material, this has to be done manually and the correct IDs assigned to the source geometry.

I hope that helps,

Many thanks,

Paul
Paul Roberts
iToo Software

TQ2576

  • Newbie
  • *
  • Posts: 12
Re: Material ID Strange
« Reply #3 on: September 15, 2014, 01:04:38 PM »
Great thanks all.  That makes a lot of sense now to me but I am getting one tile on the wrong material ID.

Rokas

  • Sr. Member
  • ****
  • Posts: 406
Re: Material ID Strange
« Reply #4 on: September 15, 2014, 01:18:37 PM »
Great thanks all.  That makes a lot of sense now to me but I am getting one tile on the wrong material ID.

You have turned on Debug Mode (the last rollout).
Why it`s different in debug- i have no idea,- but disabling debug mode fixes the problem.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Material ID Strange
« Reply #5 on: September 15, 2014, 01:32:07 PM »
Hi,

Yes debug mode is a v-ray specific tool that allows you to assign a specified material idea only to instanced segments , this allow you to identify which of your segments are instances and which are unique geometry. You can find out more about it in our documentation.

Cheers,

Paul.
Paul Roberts
iToo Software

TQ2576

  • Newbie
  • *
  • Posts: 12
Re: Material ID Strange
« Reply #6 on: September 15, 2014, 02:02:48 PM »
Rokas & Paul.....You guys Rock.  Thank you so much for your help with this.  Looks much better now so I can focus on getting this ceiling working properly now that materials are solved.
Once again thank you both for solving this and taking the time to teach me.