Itoo Software Forum

Author Topic: multi material for segments array issue with material not rendering  (Read 120 times)

grue

  • Newbie
  • *
  • Posts: 28
hello, i have a rectangle that i am trying to array two carpet tiles in.  when i assign the two segments (one green carpet square and one grey carpet square), the material does not render.  i found this in the help files:

Quote
Problem

When creating a RailClone object each segment has a material applied to the source objects, For some reason the RailClone object renders without these materials but with the Railcone wire colour.
Solution

This is because unlike Forest Pack, RailClone does not automatically consolidate materials and reassign IDs automatically.  At present you need to create a Multi-Sub object material that uses the same material IDs as set on the source geometry, so the same material applied to both RailClone object and the individual components yields the same results.

i did this and it worked great!

ultimately, i have 4 green carpet tiles, and 4 grey carpet tiles.  so i created a a multi/sub object with 8 materials.  then,i assigned that material to 1 carpet square and arrayed it. i even used that random stepped rotation macro i learned about recently  it looks great!

however, here's a question about random segments percentage.

originally, i created 1 green carpet square and 1 grey carpet square.  then i assigned a 4 spot muti/sub material to each of them - one showing 4 variations of the green carpet and one showing 4 variations of the grey carpet.

my intention was to then wire the two segments to a randomize, and say 50%/50% for each segment. that way i knew i would have a 50/50 mix of grey and green.  in addition to that, i wanted to wire in a material id to the green segment and another for the grey segment so that the grey and the green would cycle through the 4 greens and the 4 greys.  this then would allow me to change the percent of green vs grey or vice versa.  i could say no, lets do 25% green (with 4 different green carpet tile samples) and 75% grey etc...

it looks like the fix above from the help files kind of automatically cycles through the 8 total variations of green/grey at 50/50.  but how would i modify that work-around to be able to change the percentage, but also retain the 4 total variations of green and 4 variations of grey?

thanks!

ps - i've attached an image of the render after applying the fix/work-around.  you can see in this render towards the wall and doors is a solid green carpet with 4 variations, then the middle part is the mix between green/grey, then on the right, a larger area of just solid grey with 4 variations.  the middle part is the part i'm talking about.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2514
    • iToo
Re: multi material for segments array issue with material not rendering
« Reply #1 on: June 19, 2020, 03:09:20 PM »
Hi Grue

could You please attach a simplified max file so we could be on the same page.
Rokas
iToo Software

grue

  • Newbie
  • *
  • Posts: 28
Re: multi material for segments array issue with material not rendering
« Reply #2 on: June 19, 2020, 08:46:47 PM »
i've attached a zip file.