Itoo Software Forum

Author Topic: Network Path for Railclone assets not found by Bitmap Tracking/Relink Bitmaps  (Read 453 times)


  • Newbie
  • *
  • Posts: 4
We have redirected Railclone maps,macros etc to the network path on our centralised server so that all the Artist in our studio use the same directory.
We have followed this guidline:

It seems to be working ok, although we are facing an issue that is quite confusing for the artists.
We use Bitmap Tracking and Relink Bitmaps plugins on daily basis, as default 3dsMax Asset Tracking doesn't meet our needs, these plugins however read RC assets as missing.
For some reason only default 3dsMax' Asset Tracking sees the paths as found.

If you inspect the bitmaps plugged to RC material, they are indeed located on the network location we set through Registry.
(please see attached screenshot for better understanding of the case)

As I mentioned before, this is very confusing, in the studio scenario where artists are asked to make sure all the maps are not missing before running the render, this may lead to unnecessary attempts of relinking maps and in effect not using the right ones.

Have we done something wrong while moving Railclone assets and changing paths to network location?
Is there any way of making the 3rd party plugins to see that RC assets paths aren't missing?
Many thanks.

« Last Edit: July 15, 2022, 04:47:19 PM by inkvisual »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2905

That's rather strange. Normally if Max's built in asset tracker can see it it would be visible to 3rd party libraries too. RailClone isn't doing anything particularly special here, it just adds folder locations to the Configure User Paths > External files list.

One thing maybe to note. Generally, we recommend resolving all references used by Forest with the Asset Tracker to absolute UNC paths. It's not necessary, but usually, this way you avoid any texture path issues while using distributed rendering. The "default" file handling is controlled by 3ds Max and could be adjusted under Options - Preference Settings - File Handling - Convert file paths to UNC. This way all your scenes should use UNC paths.

Paul Roberts
iToo Software