Itoo Software Forum

Author Topic: Overlapping Offset Rows  (Read 226 times)

JM2145

  • Jr. Member
  • **
  • Posts: 75
Overlapping Offset Rows
« on: December 06, 2022, 01:13:08 PM »
Hi

I'm trying to create some shingle cladding like this https://www.dezeen.com/2020/03/03/pretty-plastic-overtreders-w-bureau-sla-upcycled-products/

I've modelled the segment, and now need to get it to offset each row and overlap correctly.  What am I missing.  Admittedly I'm a Railclone Novice.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1966
Re: Overlapping Offset Rows
« Reply #1 on: December 07, 2022, 09:21:05 AM »
Hi,

Using negative Padding values should do the trick – you can for example use the bundled “Hexagonal Padding” macro, wire an additional Transform Operator, and tweak Override Padding values as needed. Please feel free to check the “Creating Hexagon Tiling with RailClone in 3ds Max” tutorial, which may help you.

Best regards,

JM2145

  • Jr. Member
  • **
  • Posts: 75
Re: Overlapping Offset Rows
« Reply #2 on: December 08, 2022, 02:07:52 PM »
Thanks this is almost perfect, but because the segments aren't perfect hexagons, the global padding setting in the macro doesn't give enough control.

As you can see in the screenshot, I need to reduce the padding in just the vertical axis to close up this gap as shown in the sample arrangement below.

EDIT: You can delete this, I completely glossed over your bit about the additional transform.  problem solved

« Last Edit: December 08, 2022, 02:09:51 PM by JM2145 »

JM2145

  • Jr. Member
  • **
  • Posts: 75
Re: Overlapping Offset Rows
« Reply #3 on: December 08, 2022, 02:14:51 PM »
Actually problem not solved, the bottom padding only seems to be affecting every other row

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Re: Overlapping Offset Rows
« Reply #4 on: December 08, 2022, 03:49:11 PM »
Hi,

Please take a look at the attached file for a possible solution. As you've pointed out, the Hexagonal Tiling Macro depends on the geometry being modelled to certain proportions to work correctly.

In the attached file, you should be able to swap in your own geometry and adjust the top padding in the Segment node to get the correct overlap. You may also want to adjust the Y rotation value.

Let me know if you have any further questions,

Paul
Paul Roberts
iToo Software

JM2145

  • Jr. Member
  • **
  • Posts: 75
Re: Overlapping Offset Rows
« Reply #5 on: December 08, 2022, 05:13:10 PM »
That sort of worked.  I had to tweak it, for some reason adjusting the padding of the segment seemed to break it above -250mm, so I simply added another Transform between your Transform and the Sequence operators and it works now.  I have no idea why it works, i,e, I don't understand what I've just done or what you've done.  But it works :)