Itoo Software Forum

Author Topic: problem with rotating RC 2SArray  (Read 903 times)

Marta

  • Newbie
  • *
  • Posts: 5
problem with rotating RC 2SArray
« on: September 18, 2014, 05:15:16 PM »
Hello,

I have such problem as below - I've created several patterns using 2S array.
But when I rotate pattern around x axis pattern itself changes and rotates strangely.
I was trying to build this geometry also in front view as I want it to be vertical, but I didn't manage at all (nothing appeared).
Please help, images below.

Though maybe I'm complicating it anyway and there is a better way to make this array with changeable patterns?


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: problem with rotating RC 2SArray
« Reply #1 on: September 18, 2014, 07:55:47 PM »
Hi,

The clipping path uses the RailClone object's local axes to determine the X/Y area, so you must rotate the Z axis of the RC object and the spline align. However if you are using the generator's Z Rotation property to create the diagonal patterns, you may have issues with the style in a vertical alignment. To prevent this, set Z Rotation to 0,manually rotate the railclone object and then reasign the clipping spline.

I hope that helps, if you are able to upload your file I'd be happy to look at it in more detail.

Kind regards,

Paul
Paul Roberts
iToo Software

Marta

  • Newbie
  • *
  • Posts: 5
Re: problem with rotating RC 2SArray
« Reply #2 on: September 19, 2014, 11:05:05 PM »
Hello :)

Thank you for fast reply - I'll upload a scene file as soon as possible :)