Itoo Software Forum

Author Topic: problem with segments - objects get sliced  (Read 1450 times)

LB2304

  • Newbie
  • *
  • Posts: 19
problem with segments - objects get sliced
« on: December 19, 2013, 11:00:14 PM »
I am trying the latest version of railclone to place cars on a path using the books tutorial.  I wanted to have random vehicles parked on spline objects but even with padding some vehicles are getting sliced.  Is there a way to get it so that the cars don't get chopped off or overlap each other?

Here is a sample of the scene with the vehicles on a path using railclone
I am using Max Design 2014 and Railclone 2.1.6

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: problem with segments - objects get sliced
« Reply #1 on: December 20, 2013, 10:28:36 AM »
Hi,

The slicing is caused by the Bevel mode found in the Generator's Properties->Rules->Corner settings. These settings control the slicing behaviour of segments when they bridge a corner (defined by a vertex of particular type) on the spline. To prevent this from occurring simply set the Bevel Mode to None and the segments will follow the path without being sliced.



I've also noticed you are randomly selecting an empty segment. If this is to add the occasional empty parking space you may need to add a padding value. When an empty segment with no padding is added to the sequence it stops anything from appearing after it.

Hope that helps,

Many thanks,

Paul
« Last Edit: December 20, 2013, 10:34:59 AM by Paul Roberts »
Paul Roberts
iToo Software

LB2304

  • Newbie
  • *
  • Posts: 19
Re: problem with segments - objects get sliced
« Reply #2 on: December 20, 2013, 04:29:00 PM »
fantastic!  Thanks Paul, I will try that out.  Much appreciated :)