Itoo Software Forum

Author Topic: Railclone 4.0.9 Crashes legacy scene  (Read 485 times)

Pictor

  • Newbie
  • *
  • Posts: 24
    • Picto Studios Ltd
Railclone 4.0.9 Crashes legacy scene
« on: October 24, 2019, 04:04:14 PM »
Hi iToo, I've just updated to Railcone 4 and it crashes a legacy scene (Max 2020). Rolling back to 3.3.1 fixes the issue.

It's the "RC Forticrete Gemini Roof Tiles" object that's the problem. Merging it crashed the scene. It appears to work fine when used as a library item.

Scene and mindump attached.

Tim

narsov

  • Newbie
  • *
  • Posts: 6
    • narsov.com
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #1 on: October 24, 2019, 05:56:20 PM »
Hi,

it crashes my scene too. I mean, I can't open it after saving with railclone 4.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3619
    • iToo Software
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #2 on: October 25, 2019, 09:26:27 AM »
Hi iToo, I've just updated to Railcone 4 and it crashes a legacy scene (Max 2020). Rolling back to 3.3.1 fixes the issue.

Hi, please try removing the Multitexture plugin from Max 2020, and tell us if there is some difference.

Thanks,
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3619
    • iToo Software
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #3 on: October 25, 2019, 09:29:14 AM »
it crashes my scene too. I mean, I can't open it after saving with railclone 4.

Hi, the problem may be different.
Please create a separated thread, include details about your Max version, the minidump, and if possible a test scene.

Thanks,
Carlos Quintero
iToo Software

Pictor

  • Newbie
  • *
  • Posts: 24
    • Picto Studios Ltd
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #4 on: October 25, 2019, 01:00:55 PM »
Hi Carlos,

I should've checked that, and you're correct, it's another Multitexture issue. The problem object has a Multitexture Mat applied.

- Scene opens fine with Max2020, RC 3.3.1, and Multitexture installed.
- Scene crashes after upgrading to RC 4.0.9.
- Scene then loads fine, after removing MultiTexture_max2020_ver2.04_64bit from the Plugins folder.

Looks like the FP/Multitexture issue is also apparent in RC.

I contacted the Multitexture guys about the FP issues earlier this week, this was their reply:

"We have been notified by itoo that there seems to be an issues, hopefully we can get it fixed, but I do not know when yet."

Tim

Pictor

  • Newbie
  • *
  • Posts: 24
    • Picto Studios Ltd
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #5 on: October 25, 2019, 01:28:14 PM »
Hi again Carlos,

I have fixed this particular scene. There are two roof multitexture mats in the scene, I was curious as to why one crashed the scene, but not the other.

The problem material had a rogue multitexture map plugged into the roughness slot of the vray shader. After removing it, it loaded fine using RC 4.0.9. I've attached two screenshots showing this.

I hope this info helps,

Tim

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3619
    • iToo Software
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #6 on: October 25, 2019, 01:36:16 PM »
Hi Tim,

Thanks for the information. As you know, we wrote to the Multitexture guys, but got no reply.
I hope they find the cause and can fix it.

Carlos Quintero
iToo Software

Pictor

  • Newbie
  • *
  • Posts: 24
    • Picto Studios Ltd
Re: Railclone 4.0.9 Crashes legacy scene
« Reply #7 on: October 25, 2019, 01:39:38 PM »
They did actually reply to us, I posted their reply in my post above.

Being a free plugin, I can't see them addressing it with any matter of priority. But fingers crossed!

Cheers,

Tim