Itoo Software Forum

Author Topic: Railclone in Scene XREF -- Free Object problems  (Read 339 times)

QE2393

  • Newbie
  • *
  • Posts: 21
Railclone in Scene XREF -- Free Object problems
« on: July 13, 2017, 03:29:31 AM »
I created a free object in Railclone.  I used this max file as an Xref Scene in another file.  If I bind the XREF to a point and rotate the point, the XREF scene acts very strangely.  I believe it is because the Rail clone source segment is rotating and changing orientation along with the RC object itself and it's creating a compounding effect which creates the unusual behavior.

Perhaps this is unavoidable -- but it seems like an Xref scene should stay "rigid" and unchanged regardless of how it is rotated.  Notably using a non-Free object seems to be okay.

Is this a bug, or unavoidable -- or perhaps there is a setting in RC for free objects that would prevent this?

I've attached an example below.  The "Scene" file bring in the RC Free file as an Xref (and rotates it with animation) so load the "Scene" to see the issue.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Railclone in Scene XREF -- Free Object problems
« Reply #1 on: July 14, 2017, 04:14:30 PM »
Hi,

That's because both the base spline and the RailClone object rotate (you can easily reproduce it in the "source" scene by rotating both objects). We´ll check what can be done to "lock" the RC object, when using the Free Object mode.

Best regards,

QE2393

  • Newbie
  • *
  • Posts: 21
Re: Railclone in Scene XREF -- Free Object problems
« Reply #2 on: July 14, 2017, 04:52:24 PM »
Right, I understand why it's happening.  It just seems very undesirable for an XREF to act this way.