Itoo Software Forum

Author Topic: railclone scene crashing  (Read 537 times)

lukx

  • Full Member
  • ***
  • Posts: 114
    • lukxCGI
railclone scene crashing
« on: July 24, 2016, 09:48:27 AM »
Got this simple scene, tried merging to new file but whatever I do it's still crashing when trying to render in vray  (when I remove railclone object it's okay.)

When the spline is straight it renders okay but when it has curves it's crashing.

Max2017 , newest railclone version
« Last Edit: July 24, 2016, 10:15:15 AM by lukx »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1539
Re: railclone scene crashing
« Reply #1 on: July 24, 2016, 03:02:54 PM »
Hi,

Thanks for reporting this and for the file. I can reproduce this issue here so we'll look into this and hopefully we can fix it as soon as possible. If you have a tight deadline there are a couple of ways you can render this now. The problem appears to be limited to 2017 so any other version should be OK, alternatively turning off Segment > Bend appears to stop crashing, or finally you can disable the instancing engine or convert RC to native instances using RailClone Tools.

Thanks again,

Paul
Paul Roberts
iToo Software

lukx

  • Full Member
  • ***
  • Posts: 114
    • lukxCGI
Re: railclone scene crashing
« Reply #2 on: July 24, 2016, 03:08:02 PM »
Thank you Paul for quick solution !

Best

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1539
Re: railclone scene crashing
« Reply #3 on: July 25, 2016, 12:13:34 PM »
HI,

Thanks again for reporting this, we have isolated the problem. It's related to using editable mesh objects or modifiers like turbosmooth that output an editable mesh for the segment's source geometry. Something has changed in the Max 2017 mesh class that's causing problems. We've already fixed it but it'll need thorough testing so will be included in the next major release. Until then please feel free to check out this knowledge base article for some easy workarounds.

I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul

Paul
« Last Edit: July 25, 2016, 12:27:01 PM by Paul Roberts »
Paul Roberts
iToo Software

KJ3909

  • Newbie
  • *
  • Posts: 1
Re: railclone scene crashing
« Reply #4 on: September 27, 2016, 06:22:42 AM »
I had a similar problem but had no Edit mesh objects.
I converted everything down to an edit poly (3hrs later) and it stopped crashing.

I'm happy to send the file if its of any help in solving the problem.

Martin

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1429
Re: railclone scene crashing
« Reply #5 on: September 27, 2016, 09:41:55 AM »
Hi Martin,

If possible, please send us the minidump file generated during the crash. Also, please feel free to send us your scene to check it here. Thanks in advance.

Best regards,