Itoo Software Forum

Author Topic: Railclone slicing ends  (Read 1792 times)

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Railclone slicing ends
« on: November 08, 2013, 04:32:04 PM »
I think I have seen the fix somewhere, but I cannot find now.
I have a straight spline using generator Array 2S.  All is good except two things.

1. At the corner of the base spline, there are continuous joints in Z axis.
2. The geometry at each end of the spine, are getting sliced and left "open" and I can't fix it.

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: Railclone slicing ends
« Reply #1 on: November 08, 2013, 05:05:01 PM »
Well,  I found in the support docs this...
To prevent clipping of segments at the start or end of the path:

It is possible to automatically scale segments so that they fill a path with only whole segments, avoiding clipping at the start or end. Assuming you already have a segment in the default input:

    From the Generator’s properties, go to Rules>Default and set the mode to Adaptive.
    Set the Adaptive Percentage to control the minimum length of remaining space before a new segment is added (see the section below for a more detailed explanation).

Tried it out and it worked, but it completely changed the coursing to stacked.  Also (see pic) the coursing switches from common to stacked from one end of RC object to the other end.

Please advise, thank you!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Railclone slicing ends
« Reply #2 on: November 08, 2013, 05:22:10 PM »
1) Probably the joint is result of the Bevel feature. You can disable it, or define what type of vertices generates bevels at Generator->Rules->X Bevel.
2) RailClone doesn't cap the ends of the sliced segments. Usually this is solved creating "Start" and "End" segments.

In the following post you can find a sample scene to create a common bond pattern. It may be helpful for you:
http://forum.itoosoft.com/index.php?topic=1602.msg5781#msg5781
Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: Railclone slicing ends
« Reply #3 on: November 08, 2013, 05:38:26 PM »
1)  Well, switching to adaptive actually solved the joint problem, too.
2)  That is where I started (the example scene.)  So, I will try to add end and start segments!

Thanks for the help again.