Itoo Software Forum

Author Topic: Random by Segment Error  (Read 409 times)

TE2862

  • Newbie
  • *
  • Posts: 2
Random by Segment Error
« on: July 20, 2016, 07:39:00 PM »
Hello,

I'm trying to use Random operator (By Segment) to create random length of a tile (Y Size) and complete the rest of the width with another tile. The first segment Y Size is calculated by a Random operator and the Second Tile length is Simply (Y Size - Segment Y Size) but I get a weird look from the rail clone. I spent ours trying to solve the problem by use a 2nd spline generator, sequence on Y, Top Side, Bottom side but with no luck.

I think there is a problem or I misused the Random operator. Any Suggestion ?

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1539
Re: Random by Segment Error
« Reply #1 on: July 20, 2016, 09:09:55 PM »
Hi!

Thanks for contacting us. I've attached a sample file that I hope helps to answer your question. It produces results similar to this:



To achieve that I've used the following technique

- A clipping spline is used to set the size of the area, though you could also have used X/Y splines or dimensions if you prefer. With a clipping spline if you want the rows to be vertical you can simply enter a value of 90 degrees for the Clipping Area > Z Rotation property.
- The blue segment is added to the generator's Left input via a transform operator that randomises the size.
- The remaining box is wired to the Default input.
- The generator's Rules > Default Segment mode is set to Scale. This will ensure that the segment wired to the default segment fills the remaining space.



I hope that helps, please let me know if you have any further questions.

Many Thanks,

Paul
Paul Roberts
iToo Software

TE2862

  • Newbie
  • *
  • Posts: 2
Re: Random by Segment Error
« Reply #2 on: July 21, 2016, 04:58:05 PM »
Thanks for the help.

The solution is very simple.