Itoo Software Forum

Author Topic: Random material  (Read 230 times)

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Random material
« on: January 05, 2018, 03:11:23 PM »
Hello,
I built my own Array 2S with tiles and verge for a roof....
Now I try to understand where and how setting the random of my material ID....
I have tried with material from Rail clone library, Redland Style Tile.... but randomize is not good.. as you can see on this screenshot....
Thank you.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1538
Re: Random material
« Reply #1 on: January 05, 2018, 03:25:21 PM »
Hi,

Are you using Corona or V-Ray? There are some limitations with corona support for UVW XForm and The Material Node and RailClone colour. The solution with Corona, if the poly count is manageable, is to disable the instancing engine from the Display rollout.

I hope that helps, thanks.

Paul
Paul Roberts
iToo Software

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Re: Random material
« Reply #2 on: January 05, 2018, 03:42:49 PM »
Hi,
it's actually Corona ...
What is strange, as we can see on the screenshot, is that there is a beginningr of random on some tiles, such as those at the bottom ...

if I use a preset, and that I modify the segments, that I replace the tiles and verge by mine, it works ... on the other hand if I created my style of array 2S, as on my example, the random does not work properly.

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Re: Random material
« Reply #3 on: January 05, 2018, 03:46:19 PM »
well I just try whitout "use Instancing Engine"... for the moment it works.. ;) thank you.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1538
Re: Random material
« Reply #4 on: January 05, 2018, 03:47:50 PM »
Possibly some of the tiles were being sliced or deformed, which will removing instancing for that segment only. That's usually the reason you'll see some randomisation in non-supported renderers. If it's around the edges of the array, it sounds like that's the reason.
Paul Roberts
iToo Software

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Re: Random material
« Reply #5 on: January 05, 2018, 03:57:46 PM »
ok, I see....
here is a render ... we can see that it's randomized, but only at the level of the hue ... the texture, it repeats itself and is not randomized..
(excuse my bad english;) )

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1538
Re: Random material
« Reply #6 on: January 05, 2018, 04:01:03 PM »
Is that with instancing turned on?
Paul Roberts
iToo Software

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Re: Random material
« Reply #7 on: January 05, 2018, 04:03:30 PM »
no turned off....

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Re: Random material
« Reply #8 on: January 05, 2018, 04:11:00 PM »
Paul, i've got the solution... I apply an UVW Map on, and set it in box... and it works well now... ;)
thank you for helping!!
Regards.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1538
Re: Random material
« Reply #9 on: January 05, 2018, 04:16:20 PM »
Great - glad to hear you've solved it. I hope that Corona will soon be able to support RailClone colour.
Paul Roberts
iToo Software

yanosh HRDY

  • Newbie
  • *
  • Posts: 9
Re: Random material
« Reply #10 on: January 05, 2018, 04:19:55 PM »
I realy hope too.. !! ;)