Itoo Software Forum

Author Topic: RC Object Update  (Read 1736 times)

Lucutus

  • Newbie
  • *
  • Posts: 9
RC Object Update
« on: October 24, 2013, 08:14:36 AM »
Good morning everybody,

im facing the following problem. I m trying to use RC for creating an animated kind of conveyer band.
It is working fine in my viewport in preview mode, but if i render a sequence the band only moves for a few frames and then freezes and stand still.
I guess its maybe a problem in updating the RC object in reder mode.

Is there a way to fix this or a workaround?

thank you very much

Lucutus


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3093
    • iToo Software
Re: RC Object Update
« Reply #1 on: October 24, 2013, 08:30:46 AM »
How are you animating it: applying keyframes to the RC object, to the spline or something method ?

Please, send us a stripped scene to support@itoosoft.com. We´ll check it.
Carlos Quintero
iToo Software

Lucutus

  • Newbie
  • *
  • Posts: 9
Re: RC Object Update
« Reply #2 on: October 24, 2013, 08:58:32 AM »
thanks for your quick reply. i sended you the scene already. Im using a Morpher Object to "Fake" the Movement of the band btw.

yours

Lucutus

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3093
    • iToo Software
Re: RC Object Update
« Reply #3 on: October 24, 2013, 10:53:24 AM »
Thanks for the scene. I can confirm there is a problem with morpher segments; they are not properly updated.

We are investigating this issue. Ufortunately there is not a workaround at this moment. I tried baking the animation using Point Cache, but it doesn't work because the number of vertices changes.
Carlos Quintero
iToo Software

Lucutus

  • Newbie
  • *
  • Posts: 9
Re: RC Object Update
« Reply #4 on: October 24, 2013, 11:12:02 AM »
Thank you for your time.

This element is part of an actual project im working on....is it possible to say if this "problem" can be solved in the near future or do i have to complete this special thing in another way?

yours

Lucutus

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3093
    • iToo Software
Re: RC Object Update
« Reply #5 on: October 24, 2013, 12:28:52 PM »
I don't know what if causing the problem exactly. In a couple of days, we will know something more. If the problem can be solved, we'll include the fix in the next update.
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3093
    • iToo Software
Re: RC Object Update
« Reply #6 on: October 28, 2013, 12:33:22 PM »
We just identified and fixed the problem. We'll release tomorrow RailClone 2.1 final, which includes this fix.
Carlos Quintero
iToo Software

Lucutus

  • Newbie
  • *
  • Posts: 9
Re: RC Object Update
« Reply #7 on: October 29, 2013, 11:55:32 AM »
Thank you for your quick work.
Unfortunately im still facing the same problem. i updated my RC version to the one that was released today an rerendered the Scene i sended to you. Same result.
Do you have any ideas whats wrong here?

yours

Lucutus

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3093
    • iToo Software
Re: RC Object Update
« Reply #8 on: October 29, 2013, 12:25:44 PM »
Please, try turning on Display->Use Geometry Shader.

We didn't test the fix with the shader off. For some reason it fails on this mode, we'll check it.
Carlos Quintero
iToo Software

Lucutus

  • Newbie
  • *
  • Posts: 9
Re: RC Object Update
« Reply #9 on: October 29, 2013, 12:41:24 PM »
This solved the problem...thank you very much


yours

Lucutus