Itoo Software Forum

Author Topic: Road segment cut issue  (Read 135 times)

Adi S

  • Newbie
  • *
  • Posts: 14
Road segment cut issue
« on: June 21, 2020, 04:58:56 PM »
Hello guys,
I'm having issues with creating part , where i use different segment geometry (just plane with divisions, all rectangular). I divided them by material ID on spline and I used sveral Linear 1s generators. Now , cut on curved parts is not good but I expected this to happen. Is it possible to make "clean" corner continuation of different segments like this ?
What i tried next is adding middle vertices and deleted them ,to get straight line segment, . Then i divided it ,changed ID of middle part to use different Segment and still i get "broken" corners, that are on a straight line.
Is there a way to fix this ?

Dragan

  • Sr. Member
  • ****
  • Posts: 496
Re: Road segment cut issue
« Reply #1 on: June 21, 2020, 05:24:06 PM »
Hi
Can you share a simplified file so we can see why are you useing different IDs and please downgrade it to Max2017.

Adi S

  • Newbie
  • *
  • Posts: 14
Re: Road segment cut issue
« Reply #2 on: June 21, 2020, 05:43:08 PM »
Sure , here's the file.
I tried other solutions and came back to the old way . Looks a bit closer cut but it's still not connected well. I saved file to 2016 max version. Also , I tried recreating issue on new spline and it worked ok but i'm trying to fix it on existing line , if it's possible.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
    • iToo
Re: Road segment cut issue
« Reply #3 on: June 22, 2020, 08:15:43 AM »
Hi
RailClone cant merge two deformed generators at it's end/start.
You should end one generator and start another in a perfect straight line if You want them to join smoothly.

However You can use one generator  and curved road using conditional node to switch between parts using material ID.



Hope this helps
« Last Edit: June 22, 2020, 08:21:29 AM by Rokas »
Rokas
iToo Software

Dragan

  • Sr. Member
  • ****
  • Posts: 496
Re: Road segment cut issue
« Reply #4 on: June 22, 2020, 08:31:27 AM »
Hi
I create a new RC Style that may help.
I will write some important notes later... I`m in the rush right now

Dragan

  • Sr. Member
  • ****
  • Posts: 496
Re: Road segment cut issue
« Reply #5 on: June 22, 2020, 09:10:45 AM »
Hi
Here is setup info.
Style is based on a Macros that are distributed on a MASTER generator.
1. Name all Generator as "Master". That is important because Macro will use this name to get Xspline Segment Size.
2. Set Generator properties as image example. Default mode set to Count and count value set to 1. Since we are nesting Macro in the Master generator we need only one instance per Spline Section.
3. Connect  NULL segment to Corner input and set the corner vertex type to 'ALL'. That will enable the Master.XSplineSection to be considered in the calculation.
4. Now you can connect the Macro.
Macro is a simple setup, just Start/Default/End with X Size calculated from arithmetic  Master.XSplineSection.
5. If you need to separate Macros by MaterialID add Selector and set properties Index to be taken from 'X Spline MaterialID'.
note: If you don`t need some IDs e.g. ID1 and ID2 but need ID3 you just place NULL segment to those 'empty` Selector`s Inputs so you have all necessary slots active.

6. To make position adjustment toward original Spline add Transform operator and use Alignment and Fixed Transforms Y/Z to make necessary adjustments/offsets

I hope this Style make any sense to you. If you need some more info just ask  ;)

This is just an idea of how to solve it. It is 5 min setup and some transform offsets will probably have issues.
 
Best Regards
Dragan
« Last Edit: June 22, 2020, 10:20:47 AM by Dragan »

Dragan

  • Sr. Member
  • ****
  • Posts: 496
Re: Road segment cut issue
« Reply #6 on: June 22, 2020, 09:59:58 AM »
Two more note:
You will probably be needed some Mirroring. Just add Mirror operator after Selector and Check Y-axis.
I just realised if you do Y-offset with transform RC will not take this in the calculation so You may get some wrong results. So for Y-offset please use Y-offset on the Generator instead of on Transform node.
Sorry for all those additional notes.  ::)

« Last Edit: June 22, 2020, 10:03:34 AM by Dragan »

Adi S

  • Newbie
  • *
  • Posts: 14
Re: Road segment cut issue
« Reply #7 on: June 22, 2020, 12:18:13 PM »
Thankts a lot guys. I eventually used Selector to change MaterialIDs and it worked. Of course I did that before your replies which I will gladly check out today in depth after my working hours. Even though I have RailClone for a while , I didn't use it much. I always found it a bit complicated for me to learn.
But lately I've been trying to use it more often and I made some great speed improvements in my workflow so I'll try to get better with it as much as possible.
I actually only wanted to divide border road markings because of connection to another road and that crossing part I will make as custom geometry + texture it in Photoshop. And my idea seamed pretty simple and usually it worked well but in this case , on straight edge I had broken Segment issues as you could see.
I think it was more of a 3ds Max Spline issue ,rather than RailClone's.

Thanks again! If I have questions regarding your solutions , I'll post them here if you don't mind.