Itoo Software Forum

Author Topic: Rotation problem  (Read 185 times)

Remco

  • Newbie
  • *
  • Posts: 27
Rotation problem
« on: November 17, 2020, 10:43:29 AM »
Hi,

i have a problem with the rotation of Railclone objects.
when i rotate the spline the object get messed up and i can't figure out what the problem is.

@dragan - they blinds is a youre macro


Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #1 on: November 17, 2020, 10:51:18 AM »
If you can downgrade it to MAX2018 I could take a look.
But if you are creating blinds don't waste time and download a macro, it is updated and free now  ;)
https://gumroad.com/dragan_prodanic

« Last Edit: November 17, 2020, 10:53:51 AM by Dragan »

Remco

  • Newbie
  • *
  • Posts: 27
Re: Rotation problem
« Reply #2 on: November 17, 2020, 10:53:43 AM »
it is youre macro  ;D

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #3 on: November 17, 2020, 10:55:09 AM »
 :-X :-X :-X
Downgrade it to Max2018.
I`ll take a look right away :D

Remco

  • Newbie
  • *
  • Posts: 27
Re: Rotation problem
« Reply #4 on: November 17, 2020, 10:55:43 AM »
saved as 2018

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #5 on: November 17, 2020, 11:19:11 AM »
Hi.
It is your RC Object (Icon) orientation! No need to rotate just leave it on the default X/Y plane.


Remco

  • Newbie
  • *
  • Posts: 27
Re: Rotation problem
« Reply #6 on: November 17, 2020, 11:25:53 AM »
aha.. i get it.

but now i have the problem with Xref.
when i import a building and rotate is 5 degrees the same thing happens

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #7 on: November 17, 2020, 11:37:38 AM »
Difficult to say without the scene.
Can you simplify or send it via wetransfer on PM.

Remco

  • Newbie
  • *
  • Posts: 27
Re: Rotation problem
« Reply #8 on: November 17, 2020, 11:43:10 AM »
its pretty simple.

if you take the scene in the post above, Xref scene in to a new file
attach dummy and rotate it.

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #9 on: November 17, 2020, 12:10:12 PM »
I`m not sure what you are rotating.
Do not rotate RC Object, they will follow Spline Z rotation.

Display > Disable Object and you should see the orientation of RC Object. Reset Pivot to Icon Center and Rotate it back to the default position.

Try to Xref from this file.




Remco

  • Newbie
  • *
  • Posts: 27
Re: Rotation problem
« Reply #10 on: November 17, 2020, 12:21:02 PM »
Hi,

i have 2 new files, hope this makes it clear what i mean

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #11 on: November 17, 2020, 12:29:18 PM »
Xref test to MAX2108.
In the meantime, open this file and take a look at how you can use Macro with an extended setup.

« Last Edit: November 17, 2020, 12:33:35 PM by Dragan »

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Rotation problem
« Reply #12 on: November 17, 2020, 12:59:48 PM »
@IToo
please do not forget about the disappearing segment when moved outside the clipping spline even Segment>Deform>Slice is off and Generator>General>Slice Preserve is on