Itoo Software Forum

Author Topic: Should be simple - 1s array  (Read 1001 times)

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Should be simple - 1s array
« on: June 05, 2014, 11:06:51 PM »
Sorry if I am being thick, but I cannot get the object to face the correct direction.
I am placing chairs around a table and all is well, except they won't face inward no matter what I try.
I am able to get them to rotate every way, EXCEPT facing the table.  ???

I could have placed them manually ten time by now, but I want to know the process for larger projects.

Thanks in advance.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Should be simple - 1s array
« Reply #1 on: June 06, 2014, 08:42:17 AM »
Rotating the Segment 90º should do the trick: select the Segment properties in the Style Editor->Transform->Fixed Z Rotation = 90 (or -90, depending of the orientation).
Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: Should be simple - 1s array
« Reply #2 on: June 06, 2014, 01:54:18 PM »
Rotating the Segment 90º should do the trick: select the Segment properties in the Style Editor->Transform->Fixed Z Rotation = 90 (or -90, depending of the orientation).

That was actually the first thing I tried.  It did not work.  I'll get a screen of what happens though.
I'll try doing a resetxform on the geometry and see if it helps.

Thank you

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: Should be simple - 1s array
« Reply #3 on: June 06, 2014, 02:02:21 PM »
Here is after performing a resetXform, and then rotating the segment 90 and then -90.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Should be simple - 1s array
« Reply #4 on: June 06, 2014, 04:11:47 PM »
Is the Pivot of the source object aligned correctly (Z up) ?.
If so, try reassigning the object in the Segment properties, or click the Update Segments button.
Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 296
Re: Should be simple - 1s array
« Reply #5 on: June 06, 2014, 04:22:49 PM »
Carlos,

Yes, model pivot was z=up
"update segments" appeared to have no effect.

Reassigning the segment was the fix.
 ;D
Thank you for your help,
best regards,
TL1895