Itoo Software Forum

Author Topic: Simple Linear 1S1 on Helix spline  (Read 424 times)

amaury

  • Newbie
  • *
  • Posts: 2
Simple Linear 1S1 on Helix spline
« on: June 18, 2021, 03:37:52 PM »
Hello there,

Using railclone is pretty new to me so I apologize in advance for my lake of knowledge about this plugin.

So here is the situation. I'm doing a simple exercice for training purpose and I guess I'm missing a lot of things.


In the image 1, you can see a simple pal being distributed on an helix spline (the pal is set in "Stepped" mode). The rotation of each pal on the Z axis is being controled by its position on the X axis.

My first issue was that I had to plug the "Pal" segment into the "Start" input in order to get the pals straight horizontally. Otherwise, I got the result displayed in Image 2.

So my first question is : why did I need to plug the "pal" segment into the "Start" input in order to get the pals horizontally straight ? I'm not sure to understand the logic of it.

Image 1 :
https://ibb.co/31sHyRD

Image 2 :
https://ibb.co/tqw8TTd

My second (and main) issue is that it get really messy when I try to plug a Cylinder (set on "Tile" mode) acting as a pipe into the "Default" input. You can see the result on the Image 3. I'd like to fix my issue by getting my pals horizontally straigth again, but  I would like also to understand the overall logic of it.

Image 3 :
https://ibb.co/HXb5VzP

Many thanks for your help and potential advises !

Rokas

  • Hero Member
  • *****
  • Posts: 3324
Re: Simple Linear 1S1 on Helix spline
« Reply #1 on: June 18, 2021, 03:53:41 PM »
Hi and welcome. Please attach max file, preferable downgraded to lowest version You can.
Rokas

amaury

  • Newbie
  • *
  • Posts: 2
Re: Simple Linear 1S1 on Helix spline
« Reply #2 on: June 18, 2021, 04:00:05 PM »
Thank you very much for your reactivity.

I attached both a max 2018 and max2021 version of the file.

Dragan

  • Hero Member
  • *****
  • Posts: 1296
Re: Simple Linear 1S1 on Helix spline
« Reply #3 on: June 18, 2021, 04:58:18 PM »
Hi
This is a known issue with evenly on the helix. Try with the Default input with override X Size transform, but uncheck Scale segment.