Itoo Software Forum

Author Topic: Trying to put empty spaces into a railclone  (Read 486 times)

SI3457

  • Newbie
  • *
  • Posts: 11
Trying to put empty spaces into a railclone
« on: October 09, 2015, 12:04:18 PM »
Hi, this is a screenshot of a railclone of shutters in which id like to put randomly empty spaces in. When a group of shutters is in open position, i need an empty space right after for example.  How can i add an empty segment ?

thanks
« Last Edit: October 09, 2015, 12:13:41 PM by SI3457 »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Trying to put empry spaces into a railclone
« Reply #1 on: October 09, 2015, 12:27:21 PM »
Hi,

To add an empty space after a shutter segment you could enter a value in the Right Padding property. This will add a gap every time this segment is used.

If you need the space to be a randomly sized you can do that too, just follow these steps:
  • Wire the Shutter segment to a new Transform node.
  • Right click on the Transform node and export Padding > Right Padding
  • Create a new Random Number node and connect it to the exported Right Padding input

  • Select the Random Number node and set it to generate a new number for every Segment. Also enter your Minimum and Maximum values

  • Finally, select the Transform operator and ensure that Padding is turned On

Another approach to add empty spaces randomly anywhere in the array is to add a Segment node but don't add any geometry, instead just increase the Padding or X Size value to create a gap. You can then add this to a Randomise operator to add spaces to the array. You can also use the procedure described above with empty segments if you'd like the gap size to be randomised too.

I hope that helps, please let me know if you have further questions.

Many thanks,

Paul
Paul Roberts
iToo Software

SI3457

  • Newbie
  • *
  • Posts: 11
Re: Trying to put empty spaces into a railclone
« Reply #2 on: October 09, 2015, 12:35:43 PM »
haha great.
Thanks

I didnt know the "empty segment" trick. Works perfectly.

Tho the transform padding after the compose cannot work cause it pads at each segment, not after the complete compose....

But the empty segment trick is perfect.

BBye and thanks

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Trying to put empty spaces into a railclone
« Reply #3 on: October 09, 2015, 12:38:07 PM »
Great, glad we could help out. You're right that a transform node added to a compose operator affects all the segments. Instead you could add the Transform operator to the last segment before adding it to the Compose operator to get the desired effect. Anyway and empty segment works just as well :)

Many thanks!

Paul
Paul Roberts
iToo Software

SI3457

  • Newbie
  • *
  • Posts: 11
Re: Trying to put empty spaces into a railclone
« Reply #4 on: October 09, 2015, 12:42:33 PM »
ha ok nice.

Ill try to add transform in last segment of the compose .

Thank you man