Itoo Software Forum

Author Topic: Unproper scale mode in generator  (Read 1551 times)

psxcode

  • Newbie
  • *
  • Posts: 6
Unproper scale mode in generator
« on: November 23, 2013, 11:59:12 AM »
Create generator, spline, and segment.
Switch generator to scale mode.
Create couple corner vertices on spline.
Now if vertices are aligned in straight line Generator works fine,
but if you move them out of straight - Generator creates unproper results
« Last Edit: November 23, 2013, 02:57:26 PM by psxcode »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Unproper scale mode in generator (possible bug)
« Reply #1 on: November 23, 2013, 01:19:37 PM »
The result changes if Generator->Corner->Bevel is enabled or not (on by default). With Bevels on, RailClone breaks the spline at the corner vertices, creating one scaled segment by section.

What do you want to get exactly ?
Carlos Quintero
iToo Software

psxcode

  • Newbie
  • *
  • Posts: 6
Re: Unproper scale mode in generator (possible bug)
« Reply #2 on: November 23, 2013, 01:27:25 PM »
Quote
creating one scaled segment by section.
This doesnt work.
Segments are not scaled by section if vertices are not in straight line
Check it out as I described before.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Unproper scale mode in generator (possible bug)
« Reply #3 on: November 23, 2013, 01:41:31 PM »
Please, post a test scene. I don't see what is the problem.
Carlos Quintero
iToo Software

psxcode

  • Newbie
  • *
  • Posts: 6
Re: Unproper scale mode in generator (possible bug)
« Reply #4 on: November 23, 2013, 02:13:14 PM »
Box doesnt show it. Try with other geometry

In picture:
Top spline - vertices are straight.
Bottom spline - vertices slightly moved from straight

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Unproper scale mode in generator (possible bug)
« Reply #5 on: November 23, 2013, 02:49:33 PM »
Ok, i see. The geometry is extended deliberately to make a properly cut for the Bevel. Without it, the result is much worse for some styles (panels and so).

To avoid it, set Corner->Bevel to "none" in the generator properties. But then you will notice that the segment is extended along the full spline. To "break" them in each corner vertex, add a empty Segment to the Corner rule (see image).
Carlos Quintero
iToo Software

psxcode

  • Newbie
  • *
  • Posts: 6
Re: Unproper scale mode in generator (possible bug)
« Reply #6 on: November 23, 2013, 02:57:02 PM »
Aha. That was clever.
And you can use the paddings with empty segment!
Thank you!


psxcode

  • Newbie
  • *
  • Posts: 6
Re: Unproper scale mode in generator
« Reply #7 on: November 24, 2013, 01:28:36 PM »
Another issue.
Same settings, now with Composite node.
Seems like Scale by X lowers exponentially. Spline vertices are all Corner.
Please check it out
« Last Edit: November 24, 2013, 01:30:43 PM by psxcode »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3094
    • iToo Software
Re: Unproper scale mode in generator
« Reply #8 on: November 24, 2013, 02:24:00 PM »
Yes, this is a bug. We'll fix it.

The workaround is to create a segment with the two pieces attached (obvious but not elegant, i know).
Carlos Quintero
iToo Software