Itoo Software Forum

Author Topic: Use Instancing Engine v Use Segment Material  (Read 1114 times)

DT

  • Jr. Member
  • **
  • Posts: 85
Use Instancing Engine v Use Segment Material
« on: September 10, 2021, 08:57:25 PM »
Hi,

I'm trying to use curbs from Megascans as a RC object but the smoothing groups seem to be ignored. For it to be smooth again I need to turn of Use Instancing Engine, and apply a modifier. But then I noticed that Use Segment Material doesn't work. I couldn't find information on the forums or documentation, so I'd like to point this out as well.

Is there another way for the smoothing groups to be OK? Cause there's a lot of curbs.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Re: Use Instancing Engine v Use Segment Material
« Reply #1 on: September 13, 2021, 10:58:16 AM »
Thanks for the question,

This would appear to be related to the import settings of Megascans geometry. Depending on your most recently used FBX settings, it is possible that the geometry is not importing with the smoothing groups. You can check this by selecting the polygons in the curb object to see if they have any smoothing groups assigned.

To fix it, you can import any FBX object using the Import option in the File menu



And then ensure that Geometry > Smoothing Groups is checked. Open the file (You can delete it again afterwards, it's just to ensure Max remembers the recent import settings)



Now the next time you import an object from Megascans, the smoothing groups should also be imported and the object will appear identically in RailClone.

I hope that helps,
Paul

p.s For many Megascans assets, only one smoothing group is used. So another quick workaround if you don't want to reimport everything is just to add a Smooth modifier and set everything to use Smoothing Group 1




Paul Roberts
iToo Software

DT

  • Jr. Member
  • **
  • Posts: 85
Re: Use Instancing Engine v Use Segment Material
« Reply #2 on: September 13, 2021, 02:00:27 PM »
Hi Paul,

Thanks for the reply. I've used bridge to import them. The weird thing is when I import them they look good when I render them alone and in the viewport the smoothing groups look good too. But in a RC object they aren't. If I apply a autosmooth on the segment nothing changes either.

But indeed when I apply a Smooth modifier and set it to 1. It works. Very strange.

Thanks for the tip :-).