Itoo Software Forum

Author Topic: Distribution Render  (Read 7702 times)

glorybound

  • Newbie
  • *
  • Posts: 14
Distribution Render
« on: August 13, 2009, 03:42:08 AM »
Would Forest Lite keep DR from starting? I installed Forest Lite on my workstation and slaves.  V-ray is saying the the scene loaded and started, but it isn't using any cores. I am 4 hours into the scene with 10 hrs to go and the only buckets showing are the master workstation. I have DR working flawlessly so I know DR is working for me otherwise.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Distribution Render
« Reply #1 on: August 13, 2009, 11:27:29 AM »
There must not be differences between using Forest in DR or standard render... Do the slaves works using Backburner or rendering the scene interactively ?

It also may be a problem with missing textures, since Forest configures automatically the texture paths when it runs the first time in interactive mode. But in slaves nodes, the paths must be added manually (usually editing the max ini files).

The vray logs from slaves would be useful to get more information.

« Last Edit: August 13, 2009, 11:39:28 AM by Itoo »
Carlos Quintero
iToo Software

glorybound

  • Newbie
  • *
  • Posts: 14
Re: Distribution Render
« Reply #2 on: August 13, 2009, 03:08:21 PM »
Here is the v-ray log:

[2009/Aug/12|16:58:54] ============================================================
[2009/Aug/12|16:58:54] Console created, V-Ray Adv 1.50.SP3a for x64 from Apr  8 2009, 16:28:32
[2009/Aug/12|16:58:54] ============================================================
[2009/Aug/12|16:58:54] Compiled with Intel C++ compiler, version 11
[2009/Aug/12|16:58:54] Host is 3dsmax, version 12
[2009/Aug/12|16:58:54] V-Ray DLL version is 1.70.00
[2009/Aug/12|16:59:14] Starting DR session from 192.168.8.189

[2009/Aug/12|16:59:14] Receiving DR scene from 192.168.8.189

[2009/Aug/12|16:59:57] [VRender] Constructor entered (loading from file).
[2009/Aug/12|16:59:57]   Setting default filter kernel.
[2009/Aug/12|16:59:57] [VRender] Constructor done.
[2009/Aug/12|16:59:57] Loading from file.
[2009/Aug/12|16:59:57]   Loading filter parameters.
[2009/Aug/12|16:59:57] Loading done.
[2009/Aug/12|16:59:57] [VRender] Constructor entered (loading from file).
[2009/Aug/12|16:59:57]   Setting default filter kernel.
[2009/Aug/12|16:59:57] [VRender] Constructor done.
[2009/Aug/12|16:59:57] Loading from file.
[2009/Aug/12|16:59:57]   Loading filter parameters.
[2009/Aug/12|16:59:57] Loading done.
[2009/Aug/12|16:59:59] Scene loaded from "C:\Documents and Settings\Default User\Local Settings\Application Data\Autodesk\3dsMaxDesign\2010 - 64bit\enu\temp\vray_server_scene.max"

[2009/Aug/12|17:00:00] Extracting sequence data from RendParams.
[2009/Aug/12|17:00:00] Setting up V-Ray parameters for frame rendering.
[2009/Aug/12|17:00:00] Extracting sequence data from VRender.
[2009/Aug/12|17:00:00] Forcing multithreading
[2009/Aug/12|17:00:00] A render elements manager with 1 elements detected
[2009/Aug/12|17:00:00]   Render element: VRayZDepth
[2009/Aug/12|17:00:00] Current project folder is "C:\Users\vlado\Documents\3dsMax"

[2009/Aug/12|17:00:00] Entering beginSequence().
[2009/Aug/12|17:00:00]   Setting RenderGlobalContext.
[2009/Aug/12|17:00:00]   Broadcasting NOTIFY_PRE_RENDER.
[2009/Aug/12|17:00:00]   Preparing renderer...

[2009/Aug/12|17:00:00]   Creating render callback from built-in VFB.
[2009/Aug/12|17:00:00]   warning: Subpixel color mapping is on: rendered result may have incorrect brightness.

[2009/Aug/12|17:00:00]   Calling renderBegin().
[2009/Aug/12|17:00:00]     Sending RenderBegin().
[2009/Aug/12|17:00:00]       Sending RenderBegin() to atmospheric effects.
[2009/Aug/12|17:00:00]       Sending RenderBegin() to render effects.
[2009/Aug/12|17:00:00]       Sending RenderBegin() to environment maps.
[2009/Aug/12|17:00:00]       Sending RenderBegin() to the tone operator.
[2009/Aug/12|17:00:00]       Sending RenderBegin() to override mtl.
[2009/Aug/12|17:00:00]     Adding global illumination light
[2009/Aug/12|17:00:00]     Created global illumination light.
[2009/Aug/12|17:00:00]     Light added to light list.
[2009/Aug/12|17:00:00]     Scanning scene.
[2009/Aug/12|17:00:00]       Created light from node.
[2009/Aug/12|17:00:00]       Light added to light list.

glorybound

  • Newbie
  • *
  • Posts: 14
Re: Distribution Render
« Reply #3 on: August 13, 2009, 03:09:26 PM »
I am using proxies so texture paths shouldn't matter should they?  The proxies are all on a shared resources.

glorybound

  • Newbie
  • *
  • Posts: 14
Re: Distribution Render
« Reply #4 on: August 13, 2009, 03:56:55 PM »
Du!  I copied the dlo to all the slaves, but I never actually ran the installation.  Once I ran the installation the slaves it is working great. Also not only were the slaves not kicking in the master machine took 14 hrs on the one scene.  Now that all the slaves (5) are kicking in it'll take 1 hr.  Not only were the slaves not helping not having the plug-in installed on the slaves greatly slowed down the master machine.

On a side note it is great to post a question and get feedback within hours. I can't tell you how often I buy plug-ins to get no support. Thanks!
« Last Edit: August 13, 2009, 04:08:20 PM by glorybound »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Distribution Render
« Reply #5 on: August 13, 2009, 04:05:41 PM »

Ok, it makes sense. Forest uses some dll for VRay besides the plugin file. Here are the instructions for a manual installation if you need it:

http://www.itoosoft.com/english/menu.php?id=forest_install

Carlos Quintero
iToo Software