Itoo Software Forum

Author Topic: Forest pack using 64gb ram and im not even scattering anything...  (Read 1746 times)

JPJAPERS

  • Newbie
  • *
  • Posts: 4
Im trying to paint an area onto some geometry. I havent selected anything to scatter and yet its locking up max and using 64gb of RAM entirely locking up my system.  I have a 24 core machine so i dont see why im having such an issue.
« Last Edit: November 27, 2018, 02:49:31 PM by JPJAPERS »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1557
    • iToo
Re: Forest pack using 64gb ram and im not even scattering anything...
« Reply #1 on: November 27, 2018, 02:48:59 PM »
Could You please attach Your scene so we can investigate where the problem is? Only with Your feedback we could improve user experience for You and other users.

Please use this form to contact us if You can't attach files publicly.

Rokas
iToo Software

JPJAPERS

  • Newbie
  • *
  • Posts: 4
Re: Forest pack using 64gb ram and im not even scattering anything...
« Reply #2 on: November 27, 2018, 02:52:16 PM »
Could You please attach Your scene so we can investigate where the problem is? Only with Your feedback we could improve user experience for You and other users.

Please use this form to contact us if You can't attach files publicly.

Hi,

Im unable to attach the scene as its a commercial project but i can give you some further info.
We have a scene of around 200,000mm across. Im trying to paint on a plane with 300x300 subdivision. I have set the  furest scene units to 200,000. Thats all ive changed. Ive had to end the max process multiple times because of it. Scattering with splines works OK but its the paint tool specifically that is causing issues

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1557
    • iToo
Re: Forest pack using 64gb ram and im not even scattering anything...
« Reply #3 on: November 27, 2018, 04:33:51 PM »
Update:
Did some tests.
I can confirm that V5.4.1 was faster. We will investigate where the problem is.
Thanks for feedback.
Rokas
iToo Software

RickLum

  • Newbie
  • *
  • Posts: 1
Re: Forest pack using 64gb ram and im not even scattering anything...
« Reply #4 on: December 12, 2018, 01:45:53 PM »
I've noticed this as well. Could there be some kind of memory leak at play here? Just making a guess.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3441
    • iToo Software
Re: Forest pack using 64gb ram and im not even scattering anything...
« Reply #5 on: December 17, 2018, 01:43:38 PM »
Hi, in Forest 6 we included a new memory management system, much more efficient to handle large distributions (> 1 Mill. items)
Although it was working well for huge distributions, we noticed as result of this thread, that performance for small/medium distributions was worse than FP5.

Therefore, we added some changes in FP 6.1.3 beta to improve it. Now painting lag should be much less noticable.

Anyway, please note that unlike other plugins, Forest paint areas are parametric: you can change any parameter to adjust the distribution, but preserving the paint area.
So, it's unavoidable that some lags exists when painting large areas, because the full distribution must be rebuilt with each paint stroke.

If you need to paint huge areas, i would suggest to create separated Forest objects for smaller zones.
Once completed, just convert each paint area to a spline, and attach all splines in an unique Forest object.

I hope that helps.
Carlos Quintero
iToo Software