Itoo Software Forum

Author Topic: 3.9.6 question  (Read 1768 times)

OH9242

  • Newbie
  • *
  • Posts: 9
3.9.6 question
« on: January 14, 2013, 07:49:21 PM »
I have installed 3.9.6pro on top of 3.9.5pro.

Since the instalation, when I open a tree from HQcatalogue (non free), it tells me HQ plants texture paths must be included in Customize->Configure User Paths-> External Files. Do you want to add them automaticly? If not, then you must configure them manually.

Even if I choose yes, next time, I choose that tree it is asking me again. I verified the external paths, and the map folder is there. I uninstaled the catalog and reinstalled. And the same question everytime I use some of the plants.

With 3.9.5 this problem wasn`t there. Is it something wrong with this upgrade?

« Last Edit: January 14, 2013, 08:21:55 PM by OH9242 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3148
    • iToo Software
Re: 3.9.6 question
« Reply #1 on: January 14, 2013, 08:41:48 PM »

Theorically the update should not affect, because the texture paths are handled by a script installed by HQ Catalog, no by the plugin.

Please, try reinstalling HQ Catalog, and check if there is some Maxscript error in the listener (F11) when you select a plant from the library.

What Max version do you use ? We tested it here using Max 2013 and everything seems correct.

« Last Edit: January 14, 2013, 08:43:23 PM by iToo »
Carlos Quintero
iToo Software

OH9242

  • Newbie
  • *
  • Posts: 9
Re: 3.9.6 question
« Reply #2 on: January 15, 2013, 11:57:53 AM »
I`m using  3dMax Design 2013.
I also uninstalled and reinstalled HQ Catalogue.

In the listener I have this:
Welcome to MAXScript.

"Adding G:\_000 Biblioteci 3DMAX\ITOO\HQ Plants Catalog\lib\HQPlants 1\maps to user maps search path for lib HQ Plants 1"
"Adding G:\_000 Biblioteci 3DMAX\ITOO\HQ Plants Catalog\lib\HQPlants 1\maps to user maps search path for lib HQ Plants 1"
"Adding G:\_000 Biblioteci 3DMAX\ITOO\HQ Plants Catalog\lib\HQPlants 1\maps to user maps search path for lib HQ Plants 1"


I swiched between tree A, Tree B again Tree A. The program ask me every time about to add the path. The path is there as I already cheched (Even deleted the old paths from previous instalation). Interesting thing is that in 3.9.5 worked.

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: 3.9.6 question
« Reply #3 on: January 15, 2013, 02:10:33 PM »
We did some tests with the sciript in different conditions, but we unable to reproduce the problem at our side. The HQPlants script is quite simple, it does a search for a specific map in the 3dsmax map paths, if the map not found then it shows the warning.

Please try to run the following two commands in the MAXScript Listener and send us the reply. This will help us to isolate the problem:

Code: [Select]
for i=1 to mapPaths.count() do print (mapPaths.get i)
Code: [Select]
mapPaths.getFullFilePath "eucaliptus_bark_1.jpg"

Also would be usefull for us if you can try to install the 3.9.5 and check if the problem continues.
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

OH9242

  • Newbie
  • *
  • Posts: 9
Re: 3.9.6 question
« Reply #4 on: January 15, 2013, 04:31:39 PM »
problem solved :)

first command
for i=1 to mapPaths.count() do print (mapPaths.get i)


"D:\Program Files\Autodesk\3ds Max Design 2013\Maps"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\glare"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\adskMtl"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\Noise"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\Substance\noises"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\Substance\textures"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\mental_mill"
"D:\Program Files\Autodesk\3ds Max Design 2013\Maps\fx"
"C:\Users\Miru\Documents\3dsMaxDesign\downloads"
"d:\Program Files (x86)\Itoo Software\Forest Pack Pro\distmaps\images"
"d:\program files (x86)\itoo software\forest pack pro\maps\HShadows"
"d:\program files (x86)\itoo software\forest pack pro\maps\Standard"
"d:\program files (x86)\itoo software\forest pack pro\maps\Classic"
"d:\Program Files (x86)\Itoo Software\Forest Pack Pro\lib\3D\HQPlants\Free Models\maps"
"G:\_000 Biblioteci 3DMAX\ITOO\HQ Plants Catalog\lib\HQPlants 1\maps"

second comand (added "print" in front of it)
print (mapPaths.getFullFilePath "eucaliptus_bark_1.jpg")

""


So the result was empty.
Checked if picture is in maps. It was at G:\_000 Biblioteci 3DMAX\ITOO\HQ Plants Catalog\lib\HQPlants 1\maps

Then I installed 395 on top of 396 and started 3dmax.
When created a forest object a message told me that I don`t have a licence.
Opened the licence manager and I stopped the server and than started it again.
Reopened 3dmax, and now the object worked and all the tree choosen didn`t generate the path messege. So all ok.

Then reinstalled 396 on top of 395. Than restarted the server in the licence manager(I felt that this can be reason...Anyway maby not because I also restarted computer from yestarday and the problem was today too)
Than started 3dMax and all worked perfectly.

Runned again the second script command
and receicved the path (not the empty string)

"G:\_000 Biblioteci 3DMAX\ITOO\HQ Plants Catalog\lib\HQPlants 1\maps\eucaliptus_bark_1.jpg"

So glad it worked :) Still don`t know what was the problem. Maybe the result (empty string)  from the second script at first 396installation  is a good indicator for you.
« Last Edit: January 15, 2013, 04:44:09 PM by OH9242 »

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: 3.9.6 question
« Reply #5 on: January 16, 2013, 09:08:42 AM »
Thanks for the information. We will investigate the issue, it seems to be some problem related to the 3dsmax bitmap manager.

In your configuration, Is the drive G:\ is a network share or a local disk ?
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

OH9242

  • Newbie
  • *
  • Posts: 9
Re: 3.9.6 question
« Reply #6 on: January 16, 2013, 11:23:09 AM »
G is a local drive on the licence computer (the same as C and D...don`t know why is sometime "d" and somtime "D"). It is shared so it can be seen by my other computer.

As an additional info. The problem was also available from a network computer that was accessing the licence computer. On the licence computer(where I did the tests in the previews replays, had the HQlibrary and HQcatalog installed). On the other computer I only added the path to the network library(never installed HQcatalog on it, only upgraded to 396). So all worked ok in 395 on this network computer, than worked wrong with the same path question in 396, and finnaly ok after the licence computer was fixed. So practicaly the network computer didn`t suffered any changes for fixing the issue. It was influenced only by the licence computer
« Last Edit: January 16, 2013, 11:27:23 AM by OH9242 »

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: 3.9.6 question
« Reply #7 on: January 21, 2013, 02:05:05 PM »
Thanks for the information, it seems to be related to the 3dsmax path manager, we will do tests on similar scenarios to try to reproduce the issue.

If you have any similar problem, please don't heistate to contact us.
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com