Itoo Software Forum

Author Topic: Corona 1.6, FP 5.3.1/2/3b grass is changing during the production rendering  (Read 1032 times)

HK4606

  • Newbie
  • *
  • Posts: 20
Hello.

I use Corona 1.6 for my work and since the Forest Pack 5.3.1 I'm getting pretty weird grass renders. I use Edge option from Boundary checking section and DistanceToEdge effect, and I suppose this problem connected somehow with that. Please, check attached pictures. Three of them saved from the same rendering saved on different render times (you can check the stamp and the names of the pictures contain render time also). As you can see the whole grass is changing during the rendering – material color and the boundary.

I haven't see anything like this ever – object is changing during the production rendering!

I had to install Forest Pack 5.3.0 which works well in my case and I get render result which I supposed to get (picture attached too). Picture saved in the beginning of rendering with FP 5.3.3b is showing the grass as it should be, but longer render is going - worse grass looks...

Any ideas what is this?

Max 2014, Corona 1.6, tested with FP 5.3.1/2/3b

UB8512

  • Newbie
  • *
  • Posts: 29
I can confirm this issue, or half of this issue. Few days ago I was rendering similar exterior scene with FP grass preset slightly modified in forest color. I am massively using Edge option as you, but without distanceToEdge. During rendering I was changing exposure many times and suddenly grass started to be brighter and brighter. It happens me twice during rendering 21 shots. I can not confirm issue that Edge option stopped working during rendering process and grass goes through the curb, because on my two shots was different angle without visible curb or sidewalk, but probably it is the same issue too.
I simply stopped rendering and hit render button again without this issue. Probably it will be harder to reproduce...we will see.

I am also using max 2014, corona 1.6, but FP only 5.3.2 version

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Apologies for the inconveniences. We had to introduce some changes in FP 5.3.1 to fix problems with interactive rendering, that would be causing this.

Please can you confirm in this case you was using standard render, and not interactive render ?

Thanks,
Carlos Quintero
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
Yes, I confirm that I used not interactive render, in all examples here I used production not interactive render. I have this problem in all my scenes, so this is not the only example of this kind of behavior

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Ok, i forgot to ask it: do you use Backburner or other render manager ?

We'll do some tests in same conditions, and will try to reproduce the problem.
Carlos Quintero
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
I used one computer for these renders with no using any render manager

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
After several tests, we could reproduce and isolate this issue.

It happens because in Corona the Max interface is not locked while rendering. You can select objects, modify them and more.
In this case, if you move the cursor over a FP object, that may trigger a "pick" action and rebuild the object. That invalidates some data which is stored in Forest Color/Edge, which assumes that the object is not modified once that render is initialized.

This is a hidden problem which has arised now, because in the latest releases we added a security mechanism to Forest Color/Edge, to provide compatibility with Interactive Render.
Because its nature, in Interactive Render it's normal than FP objects change while they are rendered (because the user interaction). Previously, that would cause a crash... now just Forest Color/Edge is not applied temporary.

I just wrote to the Corona team to discuss about this issue. Meanwhile, you can go back to FP 5.3.0, or just avoid to move the cursor over the viewport while rendering.

Apologies for any inconvenience.

Carlos Quintero
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
Thank you for reply!

I 've just got the idea how to solve this problem from Ondra - he suggested to try "Lock 3ds Max during render" option. I've made some tests already, and it's really helps to avoid changing FP's objects during rendering. And now I even know why :)

Thanks for support!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
That's it. After checking with Ondra this issue, the solution is to lock Max during render.
He also give some ideas to implement in Forest, which may solve the problem without locking. We'll try them for next Forest updates.
Carlos Quintero
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
Great!
Thank you!

HK4606

  • Newbie
  • *
  • Posts: 20
Hello again!
Do you have any news about this problem? Ondra said that as far as he knows it's solved here, but I see this problem still. Now I'm using FP 5.4.0 with Corona's latest builds and the problem is still there. Lock 3DS Max helps, but it's not always convenient to have 3DS Max locked during rendering.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Hi, no unfortunately there are not changes yet.

We have plans to check this issue for the next major update, but there is not guarantee that we can solve it.
Max is not designed to modify the scene while rendering, and may cause undesired side effects in plugins, including ours.
Carlos Quintero
iToo Software

HK4606

  • Newbie
  • *
  • Posts: 20
Thanks