Itoo Software Forum

Author Topic: Forest pro 4.3.6 hard crash on max 2014 and max 15  (Read 2527 times)

SH3993

  • Newbie
  • *
  • Posts: 6
Forest pro 4.3.6 hard crash on max 2014 and max 15
« on: February 12, 2015, 01:26:35 PM »
Dear,

We have huge issues with forest pack and railclone. Whenever we click forest pack or railclone max hard crashes.

Every time we deinstall and install the software it works for 3 start ups.

Please help

intel core i7-5930K 3.5ghz
32 gb RAM
windows 8.1 x64
nvidia titan black
direct x runtime 11

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1549
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #1 on: February 12, 2015, 01:41:41 PM »
Hi,

Please double check, you have the latest Service Pack applied for your 3ds Max version (3ds Max 2014 / 2015). If it's not so, would you please install the Autodesk 3ds Max 2014 Service Pack 5 / Autodesk 3ds Max 2015 Service Pack 3 and give it a try?

Anyway, if the issue occurs again, would you please save and send us the minidump file of the crash to support@itoosoft.com? (You can get the minidump clicking "View report details->View report contents", checking the path of the "3dsmax_minidump.dmp" file and making a copy of it, before closing the 3ds Max Error Report window). Thanks in advance.

Kind regars,

SH3993

  • Newbie
  • *
  • Posts: 6
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #2 on: February 12, 2015, 01:53:31 PM »
Dear,

Thank you for the quick reply.

I verified and the lastest service packs of max 2014 and 2015 have been installed. Also the latest video card drivers have been installed.

I have sended the error report to support.

Thank you in advance.

ntel core i7-5930K 3.5ghz
32 gb RAM
windows 8.1 x64
nvidia titan black

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3351
    • iToo Software
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #3 on: February 12, 2015, 06:42:21 PM »
Hi, apologies by the inconveniences. We just analyzed the minidump and it crashes on a generic function used for several purposes. Unfortunately we cannot see what caused the problem exactly.

When did these crashes start ? Were the plugins working fine previously on Max 2015, or always failed ?
Had you similar problems using our plugins with other Max versions ?

Carlos Quintero
iToo Software

SH3993

  • Newbie
  • *
  • Posts: 6
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #4 on: February 12, 2015, 06:58:56 PM »
Hi,

Thank you for the research.

The problems started when switching workstation. On our old system I7 - ATI graphic card we didn't have this problem.

From the very moment we installed 3DS max 2015 with all it components the problem started. It crashed from the very beginning. Downgrading forest pack helped for 3 a 4 boots. Then it came back.
Finaly we downgraded max to 2014. There the problem came back after 1 day of use.

If you say it's generic. Do you think it's a hardwareproblem? Of softwareproblem? Will it help to send you teh crashdumpfile of 2014 and 2015?

Thx

ntel core i7-5930K 3.5ghz
32 gb RAM
windows 8.1 x64
nvidia titan black


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3351
    • iToo Software
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #5 on: February 12, 2015, 07:26:03 PM »
I think it's a software problem, but not sure if caused by our software or some Windows component.
Crash occurs in a function used to launch CPU threads. It's widely used and very dependent of the OS. Unfortunately, the error log doesn't show more information (not rare when analyzing minidumps). We have not similar cases reported either.

Please, send us the minidump of 2014 to be sure it's the same problem.

Thanks,
Carlos Quintero
iToo Software

SH3993

  • Newbie
  • *
  • Posts: 6
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #6 on: February 12, 2015, 07:37:47 PM »
Thx for the reply,

I sended a new crashdumpfile of 2014. Now generated with railclone. I hop this doesn't give any problem.

I tested it on a equal workstation here in the office and there no problem after installing the latest versions. So it's a software problem.

A windowscomponent probably. Mayby a registry problem?

thx you

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3351
    • iToo Software
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #7 on: February 13, 2015, 02:17:29 PM »
Thanks for the new minidumps. We continue working on this, trying to identify common components in Forest/RailClone that would cause this problem.
I'll post here as soon as we have some news.
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3351
    • iToo Software
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #8 on: February 14, 2015, 10:32:58 AM »
Although we cannot reproduce the problem, we made a change in the code that i hope can help.
I just sent you a Forest patch by e-mail. Please, try it and tell us if there is some difference. If it works, we'll patch RailClone as well.

Thanks,
Carlos Quintero
iToo Software

SH3993

  • Newbie
  • *
  • Posts: 6
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #9 on: February 16, 2015, 09:07:59 AM »
Thank you for the patch delivered.

The first 5 tries where good. Afterwards the problem re-occured. It started after i launched railclone once to.

Mayby when the 2 are patched the problem is dissapears.

Thx for the effort.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3351
    • iToo Software
Re: Forest pro 4.3.6 hard crash on max 2014 and max 15
« Reply #10 on: February 16, 2015, 10:11:36 AM »
Great news. I just sent the RailClone patch by e-mail.
These fixes will be included in the next FP and RC releases, so you won't need more patches.
Carlos Quintero
iToo Software