Itoo Software Forum

Author Topic: Grass on slope misbehaves  (Read 806 times)

Haider of Sweden

  • Newbie
  • *
  • Posts: 41
    • Portfolio
Grass on slope misbehaves
« on: July 04, 2016, 07:25:55 AM »
Hi!

Would you please have a look at the attached image.
This is simply a preset out of the box, Common Grass 01 (detail), and the outcome of it looks like that only on the slope. Other presets do not behave like this.

What could the reason be?
//Haider

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: Grass on slope misbehaves
« Reply #1 on: July 04, 2016, 09:31:40 AM »
Hi,

Please feel free to check this "Choppy scatter on slope" tightly related thread.

As mentioned there: "I would suggest you to check the Direction settings under the Surface tab (probably is actually set to 100). In case of large clumps I would recommend you to set it to Surface's Normal (0). Also, specially for these purposes, you can take advantage of Scale to fit sloped area feature. You can find more about these settings in our on-line reference guide."

Also, might be, that "used grass patches are too big for such surface and even facing to terrain normal and scaling them accordingly doesn't fix such look.

Using smaller clumps on problematic areas should fix it. I would suggest you to activate the Slope Range limit for that Forest object and make a copy of it. Within this second Forest object use smaller patches / detailed preset to cover the rest of the Slope Range."


Hope you'll find it useful.

Best regards,

Haider of Sweden

  • Newbie
  • *
  • Posts: 41
    • Portfolio
Re: Grass on slope misbehaves
« Reply #2 on: July 06, 2016, 10:49:53 AM »
Using smaller clumps on problematic areas should fix it. I would suggest you to activate the Slope Range limit for that Forest object and make a copy of it. Within this second Forest object use smaller patches / detailed preset to cover the rest of the Slope Range."[/i]

Thanks Michal, this is in fact what solves the issue. I learned that different presets use different climp size (hard to tell when you see the thumbnail with grass on a flat area)
//Haider