Itoo Software Forum

Author Topic: Painted area does not move along when the surface is moved  (Read 530 times)

trimitek

  • Newbie
  • *
  • Posts: 27
    • My models @ TurboSquid
Painted area does not move along when the surface is moved
« on: January 08, 2016, 02:48:21 PM »
Hi there,

Just started using Forest Pack Pro and loving it so far.
I just noticed something that probably needs to be fixed.
I had painted some areas on the surface I use for the plants, but I had to move it afterwards (on XY plane) and I found out that the painted areas stay in their original coordinates and does not move along with the surface.
Any way to avoid repainting them?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: Painted area does not move along when the surface is moved
« Reply #1 on: January 08, 2016, 03:58:35 PM »
Hi,

Well, as that's not always desirable behaviour, by default the Paint Area isn't linked to the surface.

Anyway, it's easy to bind any Area(s) to the surface with the 3ds Max's Select and Link function. Optionally, if wanted to not link the whole Forest object, you can use the Areas - Convert to Spline feature and Select and Link just that newly created & assigned spline.

Just take in mind, you'll need to click on the Update surfaces data button or mark the Auto check-box (to Update surface data automatically - this may add a performance hit for complex surfaces) to rebuild the Forest object.

Hope that helps.

Best regards,

trimitek

  • Newbie
  • *
  • Posts: 27
    • My models @ TurboSquid
Re: Painted area does not move along when the surface is moved
« Reply #2 on: January 08, 2016, 04:10:19 PM »
Thanks for the great tips!
Excellent support as always :)