Itoo Software Forum

Author Topic: Automatic Absolute Map Paths for HQPlants?  (Read 3123 times)

alexrecentspaces

  • Newbie
  • *
  • Posts: 26
  • Recent Spaces
    • recentspaces.com
Automatic Absolute Map Paths for HQPlants?
« on: April 25, 2013, 11:37:14 AM »
Hi folks,

Is it possible to somehow force all maps for the HQPlants to point to a specified location? What I mean is that when I create a new Forest object and add something from, say, HQPlants2 library, all the maps on that object (whether it's xrefed in or local to the file) point to the following dir:

E:\HQ_Plants_2\maps

What I would love is for forest to automatically re-path all maps for these files to my resources dir:

Z:\3DModels\!itoosoft\hq_plants_2\hq_plants_2\maps

And so on for the others.

Is this possible somehow without having to go through the asset tracker and repath manually every time? What I do not want to do is add these paths as custom User Paths because the maps will be "Found" on DR nodes. I need them to be "Ready" and absolute paths so I can be sure they are the correct maps.

Many thanks,
Alex York
Recent Spaces

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #1 on: April 25, 2013, 12:04:56 PM »

Would be very problematic to add this functionality, because it should work with multiple paths (at least one for each library), allowing to the user to define these paths in some way... too complex, at the end we would be creating a tool similar to the Asset Tracker.

As general rule, we try to not replicate functions which can be done with the standard Max tools (in this case the Asset Tracker and the User's paths).

Carlos Quintero
iToo Software

alexrecentspaces

  • Newbie
  • *
  • Posts: 26
  • Recent Spaces
    • recentspaces.com
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #2 on: April 25, 2013, 12:06:27 PM »

Would be very problematic to add this functionality, because it should work with multiple paths (at least one for each library), allowing to the user to define these paths in some way... too complex, at the end we would be creating a tool similar to the Asset Tracker.

As general rule, we try to not replicate functions which can be done with the standard Max tools (in this case the Asset Tracker and the User's paths).



Ok thanks for letting me know. I guess one other alternative would be to go into each max file for the HQ libraries and repath all the maps. Maybe there's a script to do this out there... would save a huge amount of time repathing everything on every project.
Alex York
Recent Spaces

KJ4602

  • Newbie
  • *
  • Posts: 8
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #3 on: June 09, 2013, 07:43:24 PM »
Hello,

It seams that I'm currently dealing with this same configuration problem...
When I pick the library path wich is located on a network dirve (O:) forest pack install the library without any problem, but the maps get another location, direct from the drive and not from network drive wich results in missing maps on the render slaves.
I'm now trying to force the maps from the "Distribution Map" rollout to be looked at my maps drive, to allow access by the render slaves, but I couln't figure how, is this possible?

Thank you in advance.
Kind regards,
Gonçalo Próspero

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #4 on: June 09, 2013, 07:49:30 PM »

Just add your network paths to Customize->Configure User Paths->External Files. Max will search the maps files in these folders.

In case you can't run Max interactively (i.e. the render nodes), the texture paths are defined in the following ini file:

C:\Documents and Settings\<username>\Local Settings\Application Data\Autodesk\3dsmax\<max version>\enu\3dsmax.ini   (see the [BitmapDirs] section)

Carlos Quintero
iToo Software

KJ4602

  • Newbie
  • *
  • Posts: 8
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #5 on: June 09, 2013, 08:56:41 PM »
Probably I was messing around with something... get "Distribution Map" working with network rendering.
For the first issue I´ve pointed out, as far I undertand there is no other solution other than manualy change the path for the bitmaps in the HQplant materials right?
Note: I do have network path for each maps directory of HQ plants

kind regards

« Last Edit: June 09, 2013, 09:00:38 PM by KJ4602 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #6 on: June 09, 2013, 09:46:15 PM »

There is not reason to get the Distribution Map from a network location, since it is installed with the plugin and loaded locally. Anyway, it also can be loaded from the User's Paths if it's not found.

It is not necessary either to change the paths of bitmaps in HQ Plants. Max will search them in the User's Paths, if they are not available in the default location.

This behaviour is not specific of Forest or HQ Plants, but a standard Max procedure. You can find more information in the Max documentation, see the Asset Tracker and related topics.

Carlos Quintero
iToo Software

KJ4602

  • Newbie
  • *
  • Posts: 8
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #7 on: June 09, 2013, 11:45:08 PM »
Well... I don't know what I'm probably doing wrong.
Attached there is a screen grab from where it can be seen the problem I currently have.
To avoid this I have to relocate the bitmaps to (O:/etc..) instead of (E:/etc...) from where only the main machine can pick the map.
The path I gave to forest pack to locate the library was (O:etc..) not (E:/etc...)
Note: Both machines have the exactly same user configuration path.

Please don't take me wrong, I'm not here to complain, just asking for some help if possible.

Cheers
« Last Edit: June 09, 2013, 11:47:53 PM by KJ4602 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #8 on: June 10, 2013, 12:48:35 AM »

The configuration of User's Paths seems correct, but probably the render node has not access to the O:/ unit. This may happen, for example, if the render service (do you use VRay DR ?) runs with a different user account.

I suggest adding the network paths in UNC format, usually that solves many problems. Be sure also the slave has access to the shared folders.

Carlos Quintero
iToo Software

KJ4602

  • Newbie
  • *
  • Posts: 8
Re: Automatic Absolute Map Paths for HQPlants?
« Reply #9 on: June 10, 2013, 01:54:19 PM »
That worked!!!  ;D :) Thaaaank you very much!

cheers