Itoo Software Forum

Author Topic: Adding a fencegate to an existing railclone object  (Read 347 times)

Soluna

  • Newbie
  • *
  • Posts: 25
Adding a fencegate to an existing railclone object
« on: March 31, 2021, 02:14:01 PM »
Heyho :)

I found this tutorial a couple of days ago:

https://www.youtube.com/watch?v=zH2bWo4yDxQ&list=PLaHaTGGXkh9vMgNFi0MDa3bMy906oNRmJ&index=4&t=29s

This is exactly the shape I was looking for! Because I´m working on a client project who´s a bit in a hurry I thought I ask here if someone can help me solving this problem:

I used the scene files of that project to create a fence and just modified them a bit. That worked nicely. But now the customer wants a fencegate at a certain position in the fence. I thought I could use markers to be a bit more flexible (just in case he doesn´t like the position where it´s at and wants me to change it). But sadly once I add my modeled fence gate to the marker input in Railclone, it doesn´t really work. Is there any way to fix this without ruining the whole weaving pattern?

Thanks a lot in advance for your help!

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Adding a fencegate to an existing railclone object
« Reply #1 on: March 31, 2021, 02:35:14 PM »
As I can see  you are connected to the X evenly instead the X Marker.
Also, for X Marker to work you need to add RC Spline modifier on the Spline and add/set the Marker position.
« Last Edit: March 31, 2021, 02:38:47 PM by Dragan »

Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #2 on: March 31, 2021, 02:40:47 PM »
In the X evenly of the top generator there´s the Null (that´s from the tutorial file in order to make this setup work) and in the bottom one there´s a branch which I´m using as fence post which has to be in the X evenly cause the posts are evenly distributed. All that works fine. But the gate doesn´t. The gate itself isn´t connected on the screenshot. That´s the 3 nodes on the bottom. When I try to plug them in the X Marker of either the bottom or the top generator, it doesn´t work.
I´m already using the RC Spline modifier and setting up the markers usually works for me but not with this weaving pattern. I attached 2 more screenshots that probably show my setup a bit better.
« Last Edit: March 31, 2021, 02:46:44 PM by Soluna »

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Adding a fencegate to an existing railclone object
« Reply #3 on: March 31, 2021, 02:47:15 PM »
Aha.. sorry I didn't pay attention to the style.
Can you please share the scene for the lower max version, 2018?

Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #4 on: March 31, 2021, 02:56:16 PM »
Sure! :) I had to upload it to Google Drive. Even though I already removed all of the unnecessary parts of the scene the file is still too big to upload it here.

https://drive.google.com/file/d/1OoqfcMOn3N_GAzafmyHzwBvGcxDqGLhO/view?usp=sharing

Thanks again!!

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Adding a fencegate to an existing railclone object
« Reply #5 on: March 31, 2021, 03:27:58 PM »
Hm, I think this will not work easily with the A2S generator.
I don't have time at the moment to find an easy solution although I think Rokas will find one in few minutes, but I`ll take a look later.
Maybe you could try with Corner input with a unique Vertex type on the spline instedad of markers.


Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #6 on: March 31, 2021, 03:48:57 PM »
I just tried that with the corner input. Not 100% sure if I did everything correctly but it didn´t really work for me either. The problem is still that the fence is not removed at the area where the fence gate is supposed to be.

But thanks again already!

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3261
    • iToo
Re: Adding a fencegate to an existing railclone object
« Reply #7 on: March 31, 2021, 03:52:09 PM »
You are not using anything to remove the fence:
Rokas
iToo Software

Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #8 on: March 31, 2021, 04:15:38 PM »
I´m not sure if I understand what you mean  :(

What should I use to remove the fence? I tried plugging in pretty much everything in the X Marker slot of the top generator but nothing worked :/ With the facade I created it worked when I used the marker. But there I only used the L1S generator and not the L2S.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3261
    • iToo
Re: Adding a fencegate to an existing railclone object
« Reply #9 on: March 31, 2021, 04:20:26 PM »
You are generating Gates with bottom generator, right ?
Top generator creates fence.

You need gap in fence(top generator) where X marker in gate (bottom generator) are placed. If I understand correctly.

For gaps it is common to use Empty segment with fixed size as the gap.
« Last Edit: March 31, 2021, 04:42:12 PM by Rokas »
Rokas
iToo Software

Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #10 on: March 31, 2021, 04:33:48 PM »
The top generator creates the weave pattern. The bottom one is for the fence posts. I tried adding an empty segment but that didn´t work for me.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 3261
    • iToo
Re: Adding a fencegate to an existing railclone object
« Reply #11 on: April 01, 2021, 08:17:17 AM »
I think it would be sensible to place gates using Material ID limits instead of the marker.
Rokas
iToo Software

Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #12 on: April 01, 2021, 04:31:23 PM »
Hmm yea. That could work. I´ll give that a try! Thanks!!  :)

Dragan

  • Hero Member
  • *****
  • Posts: 709
Re: Adding a fencegate to an existing railclone object
« Reply #13 on: April 01, 2021, 04:41:11 PM »
Or, you can try with nesting and few L1S...


Soluna

  • Newbie
  • *
  • Posts: 25
Re: Adding a fencegate to an existing railclone object
« Reply #14 on: April 03, 2021, 05:54:20 PM »
Or, you can try with nesting and few L1S...

I have to say that I´m speechless! I´m still pretty new to Railclone and haven´t really worked with the nested generators yet but WOW! That works so perfectly!! I really can´t thank you enough!!!