Itoo Software Forum

Author Topic: License Bug  (Read 313 times)

JK1258

  • Newbie
  • *
  • Posts: 34
License Bug
« on: May 31, 2022, 04:16:34 PM »
Hi,

I have recently installed max 2023.
Win 10, all updated, RC 5.2.2, FP 7.4.1

We are using network licenses. RC and FP can't find a license few times a day. It is getting really dumb. Sometimes i have opened few instances of 3ds max. In 3 of them i can use Itoo and it can see the liecese, but other two (the same max, the same machine, no virtual machines) says that there is no free license.
I have to start and stop this license manager every time that occures on any machine.

Best,
Mike

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3969
    • iToo Software
Re: License Bug
« Reply #1 on: May 31, 2022, 05:00:55 PM »
Hi,

When a license is assigned to a workstation, additional Max instances in the same computer use the same license. So theorically this issue should not happen.

Please try enabling the debug mode in the License Server, and send us the log file (License Server->Server Tab->View log). You also can find the log at C:\ProgramData\Itoo Software\licserv.log.
If possible, take note of the date/time, and the IP of your workstation when it happens, to find the related entries in the log.

Thanks,
« Last Edit: May 31, 2022, 05:03:08 PM by iToo »
Carlos Quintero
iToo Software

JK1258

  • Newbie
  • *
  • Posts: 34
Re: License Bug
« Reply #2 on: May 31, 2022, 05:34:17 PM »
Thats odd:

31/05/2022 16:07:20 I Itoo Software License Server started
31/05/2022 16:07:20 I License Server v1.5.0
31/05/2022 16:07:20 I Protocol v1.50
31/05/2022 16:07:20 W License xxxxxxxxxxx is out of support. It will not be used for plugins released after 20220502
31/05/2022 16:07:20 W License xxxxxxxxxxx is out of support. It will not be used for plugins released after 20220502
31/05/2022 16:07:20 I Loaded 4 licenses
31/05/2022 16:07:20 I License service running on TCP port 16720
31/05/2022 16:07:20 I Locator service running on UDP port 16720
31/05/2022 16:07:22 E Update lease for 192.168.1.42 failed
31/05/2022 16:07:26 E Update lease for 192.168.1.42 failed
31/05/2022 16:07:42 I Sending license xxxxxxxxxxx to 192.168.1.41
31/05/2022 16:07:48 I Sending license xxxxxxxxxxx to 192.168.1.41
31/05/2022 16:07:58 E Update lease for 192.168.1.42 failed
31/05/2022 16:32:06 W Client Thread Exception, Winsocks Error 10054
31/05/2022 16:35:29 W Lease for 192.168.1.42, product 21 not found
31/05/2022 16:35:46 W Client Thread Exception, Winsocks Error 10054


Those licenses out of support are active and payed for the next year...

But still we are using those 4 licenses at the same time most of the day

I deleted and reactivated those licenses.
I will check if the problem still occurs. But beeing able to use RC in one and not the other one max is strange.
« Last Edit: May 31, 2022, 05:57:14 PM by iToo »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3969
    • iToo Software
Re: License Bug
« Reply #3 on: May 31, 2022, 05:56:20 PM »
Probably those licenses were not updated with the renewal code you received by e-mail. This step is needed to update the maintenance end date.
It can be fixed also reinstalling the license, as you did.

But as you pointed out, that doesn't explain why a license which is assigned and working in a Max instance, doesn't work in other instances.
We'll do some tests with multiple instances, to be sure there is not some hidden problem.

P.D. I edited your post, to hide the serial numbers.
« Last Edit: May 31, 2022, 05:58:05 PM by iToo »
Carlos Quintero
iToo Software

JK1258

  • Newbie
  • *
  • Posts: 34
Re: License Bug
« Reply #4 on: June 02, 2022, 12:19:22 PM »
Hi,

Thank yopu for hiding my SN.

I have an update: One the workstations after turning on from hibernation does not see out lan for few seconds. In this time i get this in my log:

01/06/2022 09:00:51 I Itoo Software License Server started
01/06/2022 09:00:51 I License Server v1.5.0
01/06/2022 09:00:51 I Protocol v1.50
01/06/2022 09:00:51 I Loaded 4 licenses
01/06/2022 09:00:51 I License service running on TCP port 16720
01/06/2022 09:00:51 I Locator service running on UDP port 16720
01/06/2022 09:56:47 I Sending license xxxxxxxxxxx to 192.168.1.41
01/06/2022 09:56:49 I Sending license xxxxxxxxxxx to 192.168.1.41
01/06/2022 10:07:05 I Sending license xxxxxxxxxxx to 192.168.1.42
01/06/2022 12:26:45 I Sending license xxxxxxxxxxx to 192.168.1.41
01/06/2022 12:26:46 I Sending license xxxxxxxxxxx to 192.168.1.41
01/06/2022 13:06:19 I Sending license xxxxxxxxxxx to 192.168.1.42
01/06/2022 13:36:57 I Sending license xxxxxxxxxxx to 192.168.1.42
01/06/2022 14:44:28 W Client Thread Exception, Winsocks Error 10060
01/06/2022 14:50:27 W Client Thread Exception, Winsocks Error 10060
01/06/2022 15:35:46 I Lease time expired for 0.0.0.0, erase it
01/06/2022 15:35:50 I Lease time expired for 0.0.0.0, erase it
01/06/2022 15:47:36 I License free for 192.168.1.41
01/06/2022 15:47:42 W Client Thread Exception, Winsocks Error 10054
01/06/2022 15:47:45 E Update lease for 192.168.1.41 failed
01/06/2022 19:23:58 I Sending license xxxxxxxxxxx to 192.168.1.41
01/06/2022 19:26:24 I Sending license xxxxxxxxxxx to 192.168.1.41
01/06/2022 19:49:27 I License free for 192.168.1.41
01/06/2022 19:49:56 W Client Thread Exception, Winsocks Error 10054
02/06/2022 10:00:25 E Update lease for 192.168.1.42 failed
02/06/2022 10:00:29 E Update lease for 192.168.1.42 failed
02/06/2022 11:43:14 I Sending license 4888313817 to 192.168.1.41
02/06/2022 11:43:17 I Sending license 6374933552 to 192.168.1.41

192.168.1.42 is an IP of the workstation in question.

The is a max scene opened since yesterday on this PC. In that max there was an FP object and we were able to place an another one, but we cant place a new RC Object.
After opening new max we can't place new RC or FP. We have to restart the machine or the license manager service on the other PC.

Best,
Mike
« Last Edit: June 02, 2022, 12:23:14 PM by JK1258 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3969
    • iToo Software
Re: License Bug
« Reply #5 on: June 03, 2022, 09:37:15 AM »
The client exceptions shown in the log (error 10060 and 10054), just indicate a disconnection with the client.
It would happen if workstation goes offline, is suspended or there was some network issue.

Regarding the 'Update lease' errors, i guess are caused by the hibernation.
Once a license is assigned, the workstation must update it with the server periodically (every several minutes). If not, the server assumes the workstation is offline, and releases the license.

In this case, it seems the workstation tried to update their licenses, which were already released by the server.
I'm afraid our licensing system doesn't handle well this specific case, and it may be necessary to restart Max to assign a new license. We'll do some tests, and will try to improve it.

Carlos Quintero
iToo Software

JK1258

  • Newbie
  • *
  • Posts: 34
Re: License Bug
« Reply #6 on: June 06, 2022, 02:01:26 PM »
restarting Max does not affect this issue. I must restart the machine or thr license server.

JK1258

  • Newbie
  • *
  • Posts: 34
Re: License Bug
« Reply #7 on: June 21, 2022, 06:35:42 PM »
now i get error:

21/06/2022 18:30:22 W Lease for 192.168.1.42, product 21 not found

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3969
    • iToo Software
Re: License Bug
« Reply #8 on: June 22, 2022, 08:46:50 AM »
Please, enable the debug mode in the License Server, restart it, keep it working for some time, and send the full log (C:\ProgramData\Itoo Software\licserv.log) to our support team.

Thanks,
Carlos Quintero
iToo Software