Itoo Software Forum

Author Topic: Switching materials ID in Vray GPU  (Read 911 times)

Franki

  • Newbie
  • *
  • Posts: 4
  • architect
Switching materials ID in Vray GPU
« on: November 17, 2019, 05:43:20 PM »
Hey,

I have a weird problem, on my scene when I render the RC object in Vray CPU eveything is correct, mesh and material : render is matching the viewport.

When I render the same thing with Vray GPU some panels are strangely switching materials ID (from 1 to 2 in this exemple) : see the attached JPEG. I know that because when I convert the RC object in Mesh the problem occurs again and I can see that its switching mat ID.

It's very annoying considering I'm supposed to render the scene with GPU for time management.


Windows 10
3DS MAX 2019
Vray Next v2
RailClone v 4.1


Do you have any solution to this problem ?

Regards.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1759
Re: Switching materials ID in Vray GPU
« Reply #1 on: November 21, 2019, 10:29:58 AM »
Hi,

Thanks for getting in touch. It is hard to diagnose this issue - do you get the same issue with Display > Use Instancing Engine disabled? If so it could be affecting only those segments that are being sliced or deformed in some way (and therefore not instanced). I can reproduce that particular issue here and I will forward it to our development team for further investigation. Until then you should be able to render this object correctly on the GPU by disabling Use Instancing Engine from the Display rollout.


Thanks,

Paul
Paul Roberts
iToo Software

Franki

  • Newbie
  • *
  • Posts: 4
  • architect
Re: Switching materials ID in Vray GPU
« Reply #2 on: November 22, 2019, 09:29:30 AM »
Hi,

Thanks for your reply.

You're right, I juste realized that I can render properly ith the Use Instancing Engine disabled. It's working correctly that way ! It's definitely an issu that is happening with the sliced segment.

Thanks again.