Itoo Software Forum

Author Topic: VrayEdgesTexture for rounded corners  (Read 554 times)

mindmedicine

  • Newbie
  • *
  • Posts: 11
VrayEdgesTexture for rounded corners
« on: May 17, 2016, 03:09:14 PM »
Hi,

I've seen this mentioned here some time ago:

railclone: http://forum.itoosoft.com/index.php?topic=2359.0
forest pro: http://forum.itoosoft.com/index.php?topic=3211

Good news (for those who didn't know already): since more recent versions of vray : VrayEdgeTex in bump-slot for rounded corners now works on vrayProxies, vrayInstancer,...

And even better news: when using vrayProxies as segments in Railclone, it works as well.
But when using standard Max-objects (not VrayProxy) it doesn't seem to work yet...
 
In ForestPro it works correctly with VrayProxies and standard Max-objects!

Since on Vray's end it seems to be implemented now, is this something that can be fixed on Railclone's side so we don't need to convert to Vrayproxy?

Slightly related:

When using Vray RT CPU with Railclone/VrayProxies the Proxies get rendered as whatever Display option the proxy is in (bounding box, preview from file (faces), show whole mesh,...)
In most cases this is not the desired result.
 
When using preview from file (faces): vrayedgetex is used but mesh triangulation can be messed up (this is on vrayproxy's side when having a lot of ngons, etc... CAD models)
When using show whole mesh: mesh is shown and rendered correct but vrayedgestex is ignored.

In forestPro this is not an issue and works properly in every mode.

Cheers,
Tim

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1593
Re: VrayEdgesTexture for rounded corners
« Reply #1 on: May 17, 2016, 07:31:37 PM »
Hi Tim,

Thanks for contacting us. Forest Pack and RailClone do indeed now work with VRayEdgeTex maps for both proxies and standard meshes. Although until now I haven't encountered the same issues as you with RailClone. In my tests standard meshes work fine in RailClone as well as proxies. The image below show's both types.



I've attached my sample to see if you get the same results. If you have a sample scene you can send me the reproduces this issue, that could be very helpful to help us get to the cause.

Regarding using Proxies with V-Ray RT. Unfortunately V-Ray RT does not have an SDK and the RailClone implementation was handled by Chaos Group using our API. I emailed them them a little while ago about this problem and hopefully it can be resolved in a future release, however it might be worth mentioning on their forums too.  In the meantime, as you've found, if you set the Proxy Object's Display setting to Show Whole Mesh it should render fine.  If you want to cut down on the number of polygons being displayed in the viewports you can select the V-Ray Proxies, right click and select Object Properties and then turn on Display as Box. VRayEdgeTex also appears to work in my test scene using Show Whole Mesh mode.

Thanks for contacting us with these points, I hope we can resolve them soon.

Many thanks,

Paul
Paul Roberts
iToo Software