Itoo Software Forum

Author Topic: Animating With Forest Pack  (Read 1894 times)

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Animating With Forest Pack
« on: February 23, 2015, 09:40:20 AM »
Post here your questions and comments about the Animating with Forest Pack tutorial.
« Last Edit: February 23, 2015, 11:17:05 AM by Paul Roberts »
Paul Roberts
iToo Software

Rokas

  • Sr. Member
  • ****
  • Posts: 401
Re: Animating With Forest Pack
« Reply #1 on: February 23, 2015, 05:16:16 PM »
i can`t render start file- it "renders" pure black
if i switch GI from irradiance to brute force- i can... what is going on...

edit.
oh i see- mode was animation... switch to single frame = OK
« Last Edit: February 23, 2015, 05:25:18 PM by Rokas »

TSQ

  • Newbie
  • *
  • Posts: 3
Re: Animating With Forest Pack
« Reply #2 on: May 12, 2016, 11:00:49 PM »
Hi for some reason I cannot get the gradient ramp to animate my forests. Noise maps work fine but gradient ramps dont seem to work at all unless I set real world scale size to .001m, at which point it seems to only produce 3 samples (within a 10m x 10m area).  The unit scale of my scene seems fine otherwise.  What am I doing wrong? Any help appreciated.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1376
Re: Animating With Forest Pack
« Reply #3 on: May 13, 2016, 12:35:48 PM »
Hi,

As UV coordinates for the map are derived from the surface assigned under the Surfaces roll-out, I would suggest you to double check the UV mapping of such surface (that it corresponds to applied Map).

Best regards,

TSQ

  • Newbie
  • *
  • Posts: 3
Re: Animating With Forest Pack
« Reply #4 on: May 29, 2016, 03:15:36 PM »
Hi thanks for the response

Ive made my animated surface area smaller (with appropriate uv) and that seems to help but I still have to set the real world scale to very small sizes to see any effect.

Im also having another weird related problem: Ive animated my grass blowing in the wind with the gradient map now using the low poly stand-in method but once I get the final frames back from the render farm there seems to be no frame offset in the animation and all the growfx objects are animating at the same frame timeline.

Could this be because I did not cache them before hand and turn them into meshes?  Currently Im scattering growfx objects directly with growfx wind node to control animation.

Thanks




BU3717

  • Newbie
  • *
  • Posts: 1
Re: Animating With Forest Pack
« Reply #5 on: May 31, 2016, 01:24:31 PM »
Hi,
I have a problem when I want to animate object with forest pack.
I have 5 objects, animated with key frames.. they are moving when I scroll the animation bar.
When I make a forest object, I add the geometry (my 5 animated objects), I put  in the animation rollout "Follow geometry" and I untap the "animate only at render time" box...
But nothing happen when I scroll my animation bar from 0 to 100....

The originals 5 objects are still moving. But the whole population of scattered object with forest doesn't move.

what's the problem?!
thanks a lot for your help.
S.

TSQ

  • Newbie
  • *
  • Posts: 3
Re: Animating With Forest Pack
« Reply #6 on: June 07, 2016, 07:10:54 PM »
Hi

is there any solution to this problem im having?  must be something simple:

"Ive animated my grass blowing in the wind with the gradient map now using the low poly stand-in method but once I get the final frames back from the render farm there seems to be no frame offset in the animation and all the growfx objects are animating at the same frame timeline.

Could this be because I did not cache them before hand and turn them into meshes?  Currently Im scattering growfx objects directly with growfx wind node to control animation."

thanks

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1490
Re: Animating With Forest Pack
« Reply #7 on: June 08, 2016, 09:07:25 AM »
Hi!

Are you using Mental Ray and Forest Pack 5? We've identified a problem in the latest build affecting animation modes while using the mental ray renderer (which is working correctly in FP4). We've been able to fix this problem and it'll be included in the next beta version. If it's urgent please contact support@itoosoft.com and we can send you a patch.

Many thanks,

Paul
Paul Roberts
iToo Software

DD2073

  • Newbie
  • *
  • Posts: 1
Re: Animating With Forest Pack
« Reply #8 on: June 19, 2017, 03:01:58 PM »
Hi, can you pass me this file? I am not able to configure it! Thank you


Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1376
Re: Animating With Forest Pack
« Reply #9 on: June 19, 2017, 06:05:00 PM »
Hi,

Please feel free to check a similar sample scene, where the Animate by Distance to Exclude Area is applied (it allows you to control the animation frames of a distributed item based on its proximity to exclude area(s)). Hope you'll find it helpful.

Best regadrs,