Itoo Software Forum

Author Topic: Render nowhere near as dense after exporting to another Max scene  (Read 119 times)

ZeHgS

  • Newbie
  • *
  • Posts: 9
Hello!

I have a very, very large scene with countless items. For this reason, I separated it into a Foreground file and a Background one. It was working wonderfully and I managed to complete the modeling of both files separately with greater performance. However, when it was time to bring both files together and finalize my render, I ran into a problem.

The forests from my Background file were a lot less dense in the combined render than when rendered separately in their own file. I assumed it was because of the Max items parameter under Display-> Render, but changing it in the problematic forests to enormous values or even to 0, so as not to have a limit at all, did not work. Do I need to set this parameter to 0 for every single one of the dozens of forest objects I have? If not, what else could it be? I tried playing around with camera restrictions as well and though it helped a tiny bit because I had a distance falloff, it still did not even come close. Plus, this still wouldn't explain why they rendered perfectly well in their own file without changing this setting.

Thanks a lot!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3615
    • iToo Software
Re: Render nowhere near as dense after exporting to another Max scene
« Reply #1 on: July 21, 2020, 08:40:44 AM »
Hi,

In the Lite forum we provide only generic support, including questions about general  features, technical specifications, and licensing.
If you have a Pro license, please use the login credentials included with license to post in the Pro forum.

Thanks for your understanding.

Carlos Quintero
iToo Software

ZeHgS

  • Newbie
  • *
  • Posts: 9
Re: Render nowhere near as dense after exporting to another Max scene
« Reply #2 on: July 21, 2020, 09:13:37 AM »
Hello!

Thanks so much for your reply. I completely understand your stance on this. However, I would argue that this is a very general problem. My question is very simple as well as general, namely:

Which, among your general program features could possibly cause low render density when the viewport shows otherwise?

In fact, I would say your documentation is severely lacking in this regard, in particular given that the only result I was able to find while googling was this particularly dissatisfied client of yours

https://forum.itoosoft.com/forest-pro-(*)/why-are-objects-in-my-viewport-but-not-in-my-render/

I do not as of yet own a Pro license though I certainly was intending to purchase one very soon. I hope you understand my trepidation in doing so as long as a very serious - and possibly simple - issue as the one I mentioned persists.

Thanks!
« Last Edit: July 21, 2020, 09:15:53 AM by ZeHgS »

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1735
Re: Render nowhere near as dense after exporting to another Max scene
« Reply #3 on: July 21, 2020, 01:08:28 PM »
Hi,

Do you use the same System Units Setup for these files - scenes? It's really hard to say, what's happening exactly in your scene just from the provided description. Though it doesn't sound like a "limits" related issue, please feel free to disable all limits by setting these to zero - it's possible to set them from Maxscript in the following way:

$.maxdensity = 0
$.vmaxitems = 0
$.rmaxitems = 0
$.maxfaces = 0

to see if there's any difference. Also, I would recommend you to merge these scenes again into a fresh file to double-check that's not related to units.

Thanks in advance for any further comments on this issue you can share about it with us / our user community (in case some user(s) will run into similar troubles).

Best regards,

ZeHgS

  • Newbie
  • *
  • Posts: 9
Re: Render nowhere near as dense after exporting to another Max scene
« Reply #4 on: July 21, 2020, 10:18:43 PM »
Thank you very much for your kind reply!

The system units in both files are set up the same. However, for some strange reason creating a fresh scene did the trick. What I was doing before was to grab the Foreground file and save it as Fore plus Back. Then I would open Fore plus Back and import the Background file into it. What I did now was start a new scene and import both Foreground and Background individually, and it worked. Thank you for the suggestion!

Just for added knowledge, is there an easy way to select all forest objects, either through script or Forest Lister? I know that Forest Lister can do the opposite, which is to say you select them in the Max's list and then mirror that selection in Forest Lister. I would like to do the opposite because all my forest items (and I have over 80 of them) are in different groups for purposes of organization. Otherwise even through the helpful script you provided it would still have been an enormous undertaking.

Thank you very much!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1735
Re: Render nowhere near as dense after exporting to another Max scene
« Reply #5 on: July 22, 2020, 10:35:25 AM »
Hi,
I'm glad to hear that it helped. In the Forest Lister you can use to select all Forest objects in lister & to select all these marked objects in the scene, click the button. I hope that helps.

Best regards,