Itoo Software Forum

Author Topic: Macro Animate along Path  (Read 502 times)

tg

  • Newbie
  • *
  • Posts: 12
Macro Animate along Path
« on: October 07, 2019, 11:58:08 AM »
Hi,

i try to use the Railclone "Animate along Path" Macro for Car animation. The idea is to place a single car in a first Railclone object to generate a a car that travelling foreward and backward to simulate different speed of each single car. After i take this Railclone object in a second line-of-cars Railclone object. This line of cars is used on a third RC to animate the line of cars on a spline. Sounds complicated? Yes it is... ;)

Two problems appears:
- sometimes the RC animation doesn't work at rendertime. It's visible in the viewport but won't move while rendering.
- The nested travelling car don't work in the pipeline. In my opinion this is important because the animation looks very uniform, more like a train than a line of single driven cars.

It would be great if it's possible to get Railclone do this job.

The max file is attached


Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2579
    • iToo
Re: Macro Animate along Path
« Reply #1 on: October 07, 2019, 02:04:39 PM »
Hi

Thanks for interesting topic. We have looked(thanks Paul) and found this as a possible solution in Your case:



Regarding non rendering issue, please send us Your file for inspection.
« Last Edit: October 07, 2019, 02:54:01 PM by Rokas »
Rokas
iToo Software

tg

  • Newbie
  • *
  • Posts: 12
Re: Macro Animate along Path
« Reply #2 on: October 07, 2019, 03:51:27 PM »
Great Job!
Thank you very much :)

It's really fun to use your Software.
Especially your great Tutorials - they are the best on the market.

tg

  • Newbie
  • *
  • Posts: 12
Re: Macro Animate along Path
« Reply #3 on: October 07, 2019, 03:56:57 PM »
On my machine, the problem with the disappearing RC is also in the file you had uploaded.
It's only when using Vray (Vray Next update 1.2), with scanline the animation renders fine.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2579
    • iToo
Re: Macro Animate along Path
« Reply #4 on: October 07, 2019, 03:59:46 PM »
Yes, I see the problem. We will try to debug it.
Thanks!
Rokas
iToo Software

tg

  • Newbie
  • *
  • Posts: 12
Re: Macro Animate along Path
« Reply #5 on: October 08, 2019, 08:56:18 AM »
It works when you turn off "use instancing engine" in both Railclone Objects. Hope this helps

tg

  • Newbie
  • *
  • Posts: 12
Re: Macro Animate along Path
« Reply #6 on: October 11, 2019, 09:52:36 AM »
Just to complete this Thread.
It necessary to turn of the instancing engine AND use meshes or toggle the show vrayproxies as meshes on. 

PastaJackal

  • Newbie
  • *
  • Posts: 4
Re: Macro Animate along Path
« Reply #7 on: May 20, 2020, 10:32:07 AM »
Hi guys!

Was wondering if it were possible to get a sample of the setup above? A colleague and I have been trying to get railclone to simulate traffic along a multi-lane highway but are basically stumped. We're planning to plug a forestpack in to generate the cars themselves but are stuck on this one most important step.

Or if there are any decent tutorials around on how to accomplish this too, that would be fantastic.

Thank you!