Itoo Software Forum

Recent Posts

Pages: [1] 2 3 ... 10
1
Hi. i'm learning railclone and during "getting started with railclone" help part i found that if generator's rules have default mode "scale" and corner have "Bevel corner" activated it ends up with a gap at yhe corner. Is it a bug?
2
Forest Pro (*) / 6.1.1 global settings dialog broken
« Last post by Rawalanche on Today at 10:15:10 AM »
Hello,

I've just upgraded to 6.1.1 and proceeded to use global settings window to disable all the clutter, however it seems that the checkboxes are wired up wrong, they don't seem to correspond with the rollouts they disable:

For example, on the picture, I have About disabled, yet it still shows. At the same time, Tree Editor, which is enabled, is now gone.

Hopefully it can be fixed soon, this feature is the main reason I've upgraded.
3
RailClone Pro (*) / Re: Railclone windows - some questions
« Last post by Paulo R. Beck on August 18, 2018, 04:02:58 PM »
I had a similar problem, when I switch off the panel in my window (That is a nest style)  my window frame disappears
4
RailClone Pro (*) / sub array macro
« Last post by Dragan on August 18, 2018, 09:20:16 AM »
Hi
Is this a bug or I`m missing something?
Is Sub Array suppose to cover dimension of my reference plane I set below  RC spline?
The size of the Sub Array & refernece Plane is 150x200cm. Spline is 200x300cm and the Sub Array is connected to the StartButtom.

Best Regards
Dragan
5
RailClone Lite / Re: Brick Building with Noise Modifier
« Last post by iToo on August 18, 2018, 09:08:45 AM »
Hello,

Applying any modifier to the RailClone object will disable the instancing engine, and the object will be handle as a single (huge) mesh.
Unfortunately there is no way to avoid that, since is the way that the Max pipeline works.

If you want to add some variation to the bricks, i would suggest to randomize a bit the position of each segment, using a Transform node.

I hope that helps.
6
RailClone Pro (*) / Re: Animate Segment Visibility
« Last post by archaeotect on August 18, 2018, 08:54:45 AM »
After some tests I've decided that this method is simply too complicated and time-consuming. I have animated several RailClone objects with multiple generators each (which I'd have to separate), and I've randomized just about everything (transforms, MatIDs, UVWs), so I'd have to manually create an arithmetic expression and custom parameter for each individual value of each of those nodes.

Right now I'll revert to creating standalone objects with RailClone Tools and animate them manually. But thanks for the suggestion!

I don't know if this is the right place for a feature request, but it would be nice if things like this could be made easier, maybe with a macro that created (pseudo-)random values based on position (in world-space?) or a checkbox to not re-calculate random values when segment changes. Something as easy as V-Ray's "lock noise pattern" for animations.
7
RailClone Pro (*) / Re: Another Topic about Windows.
« Last post by James Vella on August 18, 2018, 07:03:36 AM »
Excellent!
8
RailClone Pro (*) / Re: Animate Segment Visibility
« Last post by archaeotect on August 17, 2018, 10:15:22 PM »
Interestingly, this seems to work on one generator only. In a RC style with multiple generators all except one still switch randomly, even though the same transform node with the arithmetic expression plugs into all generators. Once I turn this generator off, the next one works.
9
RailClone Pro (*) / Re: Another Topic about Windows.
« Last post by Paulo R. Beck on August 17, 2018, 07:33:51 PM »
It was all a matter of using the expression  YSplineLength - Input1;
Thank you very much, now I have to do the horizontal panel...

10
RailClone Pro (*) / Macro Not Working? "Animate Along Path"
« Last post by biglittlepictures on August 17, 2018, 06:13:12 PM »
I tried to use the Macro "Animate Along Path".  I linked all nodes properly and it seems to do nothing.  Sometimes the object flickers, but it certainly isn't logical.  Is there someone on the team that can further explain this macro?  It'd be awesome to use this for many uses if I could understand it and/or see a case where it is working.

Here's my use case that created the question:  Two lane highway, extruded with RC.  Using the same highway source path, use that to animate cars on both sides of the highway, going proper opposite directions.  The only way I got this to work was to create a second derivative "outline path"  in max, then make a second rail clone for the cars/trucks and use the outlined path as the flow for the cars.  To animate the flow without flicker, I unchecked "Full Length" and animated Start value.

Side note: It would be great if there were elaborated on notes for items in included macros.  This would serve as a great learning method. 
Any Help Appreciated,
-Joel
Pages: [1] 2 3 ... 10