Itoo Software Forum

Recent Posts

Pages: [1] 2 3 ... 10
1
RailClone Pro (*) / Editing the Railcone library objects
« Last post by FC1888 on October 19, 2018, 05:59:00 PM »
Can't find anyone else asking the same question, but then not really sure what to search for. Anyway, I want to be able to edit the ridge/hip models from Architecture/Exterior/Roofing/Hips and Ridges/objects.. to remove the part marked in red in the attached image from all of them, as I have done for the others you can see. The reason I do not want the end pieces is, at least in the UK, at least not on any building I have ever worked on, do you see such end tiles on the ridge and most definitely never on the hip

So what I'd like to do is create a separate library of these objects, based on edited versions of the originals of course, as I wouldn't want to mess up the original files, so I'm guessing the best way would be to use a copy.

However I have no idea how to go about it. Since I can certainly load the  rc_ridge_tiles.max file into max, but since they are RC objects, I can't just remove polys and simply resave them as a separate user library and the only way to edit them is to convert them to edit poly. So can anyone help me with this, explain the sequence of taking an existing RC object/style, editing the segments and converting them back to a railcone object/style and producing a separate new library. I can only imagine it would be a lot of work and I was thinking of asking iToo to produce a new ridges and Hips library, with those parts removed from the models, but if I can do it myself, that would certainly be great.

Here is a screen shot, showing several of the RC objects, I had to convert them to to editable  poly, only so that I can show you what I am wanting to do, all but one I have removed the unwanted parts and highlighted the last one in red

2
Oooops! I never realised that, didn't even give it a thought, thanks for that Rokas.
3
RailClone Pro (*) / Re: Paving Slabs with gaps between
« Last post by Rokas on October 19, 2018, 01:14:28 PM »
Hi

To solve and get perfect alignment I would suggest

1) Turn off Generator->"Extend X/Y Size to Area".
2) Disconnect the Clipping Area node from the generator.
3) Adjust X /Y Size and align the array visually to cover the entire area, use snapping to Your grid.
4) Connect the Clipping node again.
4
RailClone Pro (*) / Re: Paving Slabs with gaps between
« Last post by SE7479 on October 19, 2018, 09:30:21 AM »
Hi Rokas,

I've attached the file as requested. I tried to do another test just in the top viewport without any rotation to see if that was causing the issue but I still have the same problem with it not aligning correctly.

Let me know if you need anymore information, thanks for your help.

Kind regards,

Chris
5
These clumps are indeed from preset library. You can easily extract them from preset files Yourself:

6
RailClone Pro (*) / Re: Paving Slabs with gaps between
« Last post by Rokas on October 19, 2018, 08:40:47 AM »
Hi

I don't really understand info from Your screenshot but I understand that aligning can look complicated in RailClone (when using clipping splines)
Even is setup is basic it would help us to identify Your issue if You have attached Your max file.

You always can add transform operator and adjust X and Y transform values to adjust segments position.
7
First of all, excellent tutorial by the way, always look forward to seeing what is coming next, as far as tutorials go and can always be sure, than they are some of the easiest to follow tutorials, compared to many other companies.

Anyway since you cannot comment on announcements and can only comment in the tutorials sections for Forest Pack Pro OR Railclone, once a topic for them is created. I have posted this, mainly since it is the Forest Pack Pro part that it relates to.

My question about this tutorial is concerning the section on creating rugs, where you mention creating the pile and you show several examples of clumps, that could be created. However, I am wondering, would it be possible for you to share those examples. Perhaps as a new library or even sell them as a collection, same as you have done wit the 3DGarden. Yes I know you already have a rugs library, but they are presets, not a collection of parts.

Would be very helpful if this is a possibility

Thanks again for another great tutorial
8
RailClone Pro (*) / Re: Windows
« Last post by IM1808 on October 18, 2018, 07:27:48 PM »
perfect !

It works nickel, thank you!

Good in my system I have to model the windows in advance but in the end once I would have to explore 5 or 6 projects it will not be redone. Still classic curtains to add

After that and the cladding, I'm going to focus now on automating the balconies and the interiors of the rooms. Even if I saw the populate building of forest I wonder if it is not more precise with railclone for habitat ...

I imagine that by recovering the splines of interior dwg it is possible to generate a total interior RC with ID (table, photos, furniture, floors, etc ..) only problem is the multi-material that will explode ^ ^

At least he will have the advantage of being mastered.

For what it interests some RC screen of this window ...





Again thank you for the info and this plugin is excellent.
9
RailClone Pro (*) / Paving Slabs with gaps between
« Last post by SE7479 on October 18, 2018, 05:40:07 PM »
Hi all,

So I'm trying to create simple paving slabs to fill only a certain area using a spline to Extend X/Y size to area.

The issue I'm facing is that they don't line up even though they are on a grid. So later on when I add padding to create grout lines they won't be lined up.

It's all one Spline and I've increased Expand to fill the space up correctly. I've attached a screengrab showing my issue, the whitelines on the pink geometry show my issue.

I have also done this on a simple top down grid with the same problem.



The Railclone is just a very basic rectangle for the geometry and a spline.

Any help would be great, thank you,

Chris
10
RailClone Pro (*) / Re: Windows
« Last post by Rokas on October 18, 2018, 04:04:06 PM »
I see what You mean.

You should use Selector operator instead of Conditional (it only accepts one material ID) where selector selects Item Your describe in arithmetic conditions.


Use this modified expression:
Code: [Select]
return if (XSplineMatID == 12 | XSplineMatID == 112 | XSplineMatID == 22 | XSplineMatID == 122, 1,2);I have modified outputs- 1st or 2nd item from Selectors input instead a material ID You were outputting before.

Hope this helps.
Pages: [1] 2 3 ... 10